summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2016-07-26 13:20:02 -0400
committerRay Strode <rstrode@redhat.com>2016-07-26 13:33:31 -0400
commitf5ddf78c794ec48875a812b8477ea97507338122 (patch)
tree12ff26a62bfc971be966a5e58b5b7bdb7bb8cd3c /Makefile.am
parent369eab84e7a350e83587dadaa1579c24fcda4c46 (diff)
downloadflatpak-f5ddf78c794ec48875a812b8477ea97507338122.tar.gz
install dbus systemd service file snippet
flatpak currently installs a gdm env.d and a bash profile.d file to ensure XDG_DATA_DIRS is set to the right value. Neither is sufficient when the dbus daemon is activated as a system --user service. This commit adds a dbus service file snippet to frob its environment variable for that case.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9480bfb3..0814d39c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -133,6 +133,15 @@ flatpak.env: env.d/flatpak.env.in
$(AM_V_GEN) $(SED) -e "s|\@localstatedir\@|$(localstatedir)|" \
-e "s|\@sysconfdir\@|$(sysconfdir)|" $< > $@
+dbussnippetdir = $(systemduserunitdir)/dbus.service.d
+dbussnippet_DATA = flatpak.conf
+EXTRA_DIST += dbus.service.d/flatpak.conf.in
+DISTCLEANFILES += flatpak.conf
+
+flatpak.conf: dbus.service.d/flatpak.conf.in
+ $(AM_V_GEN) $(SED) -e "s|\@localstatedir\@|$(localstatedir)|" \
+ -e "s|\@sysconfdir\@|$(sysconfdir)|" $< > $@
+
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = flatpak.pc
EXTRA_DIST += flatpak.pc.in