summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2022-04-21 15:36:04 +0100
committerSimon McVittie <smcv@debian.org>2022-10-24 16:12:14 +0100
commitf85097a427e1e2ea910df29e0c592978df10e979 (patch)
tree294a78dc44f414686ed75d5aa0f0049137a6bacc /Makefile.am
parent9eb824f863fff67e5650b844bad9654f8acfb832 (diff)
downloadflatpak-f85097a427e1e2ea910df29e0c592978df10e979.tar.gz
Run a Meson build during distcheck
This verifies that all the necessary files for the Meson build are in the Autotools-built tarball. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c25dfb68..00b72cc0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -236,3 +236,14 @@ lcov-clean:
genlcov:
$(AM_V_GEN) $(LCOV) --directory $(top_builddir) --capture --output-file coverage.info
$(AM_V_GEN) $(GENHTML) --prefix $(top_builddir) --output-directory coverage coverage.info
+
+distcheck-hook: distcheck-hook-meson
+distcheck-hook-meson:
+ set -e; if command -v meson > /dev/null; then \
+ cd $(distdir); \
+ pwd; \
+ meson _build/meson; \
+ meson compile -C _build/meson -v; \
+ meson test -C _build/meson -v; \
+ rm -fr _build/meson; \
+ fi