summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2022-11-10 12:15:50 +0000
committerSimon McVittie <smcv@debian.org>2022-11-10 15:23:58 +0000
commitd28495d54f2a42b64291c02c5f6acdc95638acca (patch)
tree9ecc78fcbe24f22e1fbc8d2e71b55e75c8b8de29 /meson.build
parent9b87e4c0d4557f7ece3fedad699954a10663e41d (diff)
downloadflatpak-d28495d54f2a42b64291c02c5f6acdc95638acca.tar.gz
build: Simplify detection of GPGME when using Meson
In theory we could have ended up linking a non-threadsafe version of GPGME, since the version without the -pthread suffix has only been thread-safe since 1.8.0. In practice we require version 0.53 of Meson (available in Ubuntu 20.04, Debian 11, etc.) so it seems reasonable to require a contemporary version of GPGME (1.8.0 is available in Ubuntu 18.04, Debian 10, etc.) and drop the complexity of handling this in a fully-backwards-compatible way. Users of older LTS distributions like Ubuntu 16.04 should continue to build Flatpak with Autotools. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 1 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 755bb922..746683cf 100644
--- a/meson.build
+++ b/meson.build
@@ -208,14 +208,7 @@ build_gtk_doc = gtkdoc_dep.found()
base_deps = [glib_dep, gio_dep, gio_unix_dep]
-if meson.version().version_compare('>=0.60.0')
- gpgme_dep = dependency('gpgme-pthread', 'gpgme', version : '>=1.1.8')
-else
- gpgme_dep = dependency('gpgme-pthread', version : '>=1.1.8', required : false)
- if not gpgme_dep.found()
- gpgme_dep = dependency('gpgme', version : '>=1.1.8')
- endif
-endif
+gpgme_dep = dependency('gpgme', version : '>=1.8.0')
if get_option('selinux_module').disabled()
build_selinux_module = false