summaryrefslogtreecommitdiff
path: root/tests/test-keyring2/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/test-keyring2/meson.build')
-rw-r--r--tests/test-keyring2/meson.build13
1 files changed, 2 insertions, 11 deletions
diff --git a/tests/test-keyring2/meson.build b/tests/test-keyring2/meson.build
index 9715c4cc..0c653a08 100644
--- a/tests/test-keyring2/meson.build
+++ b/tests/test-keyring2/meson.build
@@ -1,26 +1,17 @@
# Copyright 2022 Collabora Ltd.
# SPDX-License-Identifier: LGPL-2.1-or-later
-if get_option('installed_tests')
- install_sub = installed_testdir / 'test-keyring2'
-else
- install_sub = false
-endif
-
foreach file : [
'README',
'pubring.gpg',
'secring.gpg',
]
- # TODO: When we depend on Meson 0.50.0, we can use
- # install : get_option('installed_tests')
- # instead of
- # install_dir : false
configure_file(
input : file,
output : file,
copy : true,
- install_dir : install_sub,
+ install : get_option('installed_tests'),
+ install_dir : installed_testdir / 'test-keyring2',
install_mode : 'rw-r--r--',
)
endforeach