summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--[-rwxr-xr-x]tests/Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 43b0bb8..e9f3f49 100755..100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -95,7 +95,9 @@ DIRECT_TESTS = \
include_by_push.direct \
include_by_reentrant.direct \
rescan_nr.direct \
- rescan_r.direct
+ rescan_r.direct \
+ state_buf.direct \
+ state_buf_multiple.direct
I3_TESTS = \
cxx_yywrap.i3
@@ -151,6 +153,8 @@ top_SOURCES = top.l top_main.c
nodist_top_SOURCES = top.h
yyextra_nr_SOURCES = yyextra_nr.l
yyextra_c99_SOURCES = yyextra_c99.l
+state_buf_direct_SOURCES = state_buf.direct.lll
+state_buf_multiple_direct_SOURCES = state_buf_multiple.direct.lll
# Normally, automake would distribute files built by flex. Since the
# point of the test suite is to test the files that flex builds, and
@@ -217,14 +221,16 @@ CLEANFILES = \
top.h \
yyextra_nr.c \
yyextra_c99.c \
+ state_buf.direct.cc \
+ state_buf_multiple.direct.cc \
$(RULESET_REMOVABLES)
dist-hook:
chmod u+w $(distdir) && \
for file in $(CLEANFILES) ; do \
- rm -f $(distdir)/$$file \
- chmod u+w $(distdir)/$$file \
- ; done
+ chmod u+w $(distdir)/$$file 2>/dev/null; \
+ rm -f $(distdir)/$$file; \
+ done
EXTRA_DIST = \
README \
@@ -284,6 +290,8 @@ EXTRA_DIST = \
yymorearray.txt \
yymorearraybol.txt \
yyunput.txt \
+ state_buf.direct.txt \
+ state_buf_multiple.direct.txt \
$(RULESETS)
dist_noinst_SCRIPTS = \