summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 9 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index a9e3038..6125877 100644
--- a/configure.in
+++ b/configure.in
@@ -24,22 +24,21 @@
# autoconf requirements and initialization
-AC_PREREQ(2.59)
AC_INIT([the fast lexical analyser generator], [2.5.36],
[flex-help@lists.sourceforge.net], [flex])
AC_CONFIG_SRCDIR([scan.l])
-AM_INIT_AUTOMAKE([gnits dist-bzip2])
+AM_INIT_AUTOMAKE([gnits dist-bzip2 1.10])
AC_CONFIG_HEADER([config.h:conf.in])
# checks for programs
AM_GNU_GETTEXT([external])
AM_GNU_GETTEXT_VERSION(0.12)
-
AC_PROG_YACC
AM_PROG_LEX
AC_PROG_CC
AC_PROG_CXX
+AM_PROG_CC_C_O
AC_PROG_LN_S
AC_PROG_RANLIB
AC_PROG_AWK
@@ -79,13 +78,13 @@ else
AC_MSG_WARN(no indent program found: make indent target will not function)
fi
-# checks for libraries
+# checks for headers
-AC_FUNC_ALLOCA
AC_HEADER_STDC
AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS([inttypes.h libintl.h limits.h locale.h malloc.h netinet/in.h stddef.h stdlib.h string.h strings.h unistd.h regex.h])
-AC_CHECK_LIB(m, log10)
+AC_CHECK_HEADERS([inttypes.h libintl.h limits.h locale.h malloc.h netinet/in.h regex.h stddef.h stdlib.h string.h strings.h unistd.h])
+
+# checks for libraries
# The test test-pthread uses libpthread, so we check for it here, but
# all we need is the preprocessor symbol defined since we don't need
@@ -97,6 +96,8 @@ AC_DEFINE([HAVE_LIBPTHREAD], 0, [pthread library] )
)
AC_CHECK_HEADERS([pthread.h])
+AC_CHECK_LIB(m, log10)
+
# Checks for typedefs, structures, and compiler characteristics.
AC_HEADER_STDBOOL
@@ -105,6 +106,7 @@ AC_TYPE_SIZE_T
# Checks for library functions.
+AC_FUNC_ALLOCA
AC_FUNC_FORK
AC_FUNC_MALLOC
AC_FUNC_REALLOC
@@ -116,7 +118,6 @@ doc/Makefile
examples/Makefile
examples/fastwc/Makefile
examples/manual/Makefile
-m4/Makefile
po/Makefile.in
tools/Makefile
tests/Makefile