summaryrefslogtreecommitdiff
path: root/tests/test-bison-yylval/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/test-bison-yylval/Makefile.am')
-rw-r--r--tests/test-bison-yylval/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/tests/test-bison-yylval/Makefile.am b/tests/test-bison-yylval/Makefile.am
index e55e8a7..aa9d93a 100644
--- a/tests/test-bison-yylval/Makefile.am
+++ b/tests/test-bison-yylval/Makefile.am
@@ -36,9 +36,14 @@ testname = test-bison-yylval
scanner.c: $(srcdir)/scanner.l
$(FLEX) $<
+scanner.h: scanner.c
+scanner.o: parser.h
parser.c: $(srcdir)/parser.y
$(BISON) $(YFLAGS) $<
+parser.h: parser.c
+
+main.o: scanner.h parser.h
$(testname)$(EXEEXT): $(OBJS)
$(CC) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
@@ -48,6 +53,3 @@ test: $(testname)$(EXEEXT)
.c.o:
$(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<
-
-parser.h: parser.c
-main.o: parser.h