summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAkira TAGOH <akira@tagoh.org>2012-03-16 16:29:53 +0900
committerAkira TAGOH <akira@tagoh.org>2012-03-16 16:34:37 +0900
commit93460f93e9e55e39a42fb6474918f31539436d9c (patch)
treec2cc6c53091a84386292e8f3de2266c32ad86832 /Makefile.am
parentf2813ffc689fb6972ff4d5d414c3abfa3e0be26f (diff)
downloadfontconfig-93460f93e9e55e39a42fb6474918f31539436d9c.tar.gz
Fix a build issue due to the use of non-portable variables
$< isn't supported in BSD make say. $(RM) is pre-defined in GNU make though, not in BSD make say. so changed to check on configure if it's pre-defined by make, otherwise set the appropriate command to $(RM). This would be a workaround until it has the certain pre-defined value.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 7fa1b76..9342f8e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -120,12 +120,12 @@ uninstall-local:
if [ -f $(srcdir)/fonts.conf ]; then \
if cmp -s $(srcdir)/fonts.conf $(DESTDIR)$(configdir)/fonts.conf; then \
echo " uninstall standard $(DESTDIR)$(configdir)/fonts.conf"; \
- rm -f $(DESTDIR)$(configdir)/fonts.conf; \
+ $(RM) $(DESTDIR)$(configdir)/fonts.conf; \
fi; \
else if [ -f fonts.conf ]; then \
if cmp -s fonts.conf $(DESTDIR)$(configdir)/fonts.conf; then \
echo " uninstall standard $(DESTDIR)$(configdir)/fonts.conf"; \
- rm -f $(DESTDIR)$(configdir)/fonts.conf; \
+ $(RM) $(DESTDIR)$(configdir)/fonts.conf; \
fi; \
fi; fi
@@ -136,7 +136,7 @@ debuild-unsigned: debuild-dirs
(cd $(distdir)/debian && debuild -us -uc)
debuild-dirs: distdir
- rm -f $(PACKAGE)_$(VERSION).orig.tar.gz
- rm -rf $(distdir).orig
+ $(RM) $(PACKAGE)_$(VERSION).orig.tar.gz
+ $(RM) -r $(distdir).orig
cp -a $(distdir) $(distdir).orig
- rm -rf $(distdir).orig/debian
+ $(RM) -r $(distdir).orig/debian