summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2004-12-05 07:44:08 +0000
committerKeith Packard <keithp@keithp.com>2004-12-05 07:44:08 +0000
commitfc2cc873bb1a715844a1e6f885661bf433bdd7cf (patch)
tree09f35e8233f466bdb0414bcb9df76a38a4176a92 /Makefile.am
parent308dc9c3ea0be2e0823e547f2c612760db7539a2 (diff)
downloadfontconfig-fc2cc873bb1a715844a1e6f885661bf433bdd7cf.tar.gz
Update links to new freedesktop.org locationsfc-2_2_97
Add uninstall-local to get rid of fonts.conf and local.conf if they match the distributed versions. Fixes 'make distcheck'
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c1e48a1..7079027 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -62,3 +62,27 @@ install-data-local:
$(INSTALL_DATA) local.conf $(DESTDIR)$(configdir)/local.conf; \
fi; fi; fi
if [ x$(DESTDIR) = x ]; then fc-cache/fc-cache -f -v; fi
+
+uninstall-local:
+ if [ -f $(srcdir)/fonts.conf ]; then \
+ if cmp -s $(srcdir)/fonts.conf $(DESTDIR)$(configdir)/fonts.conf; then \
+ echo " uninstall standard $(DESTDIR)$(configdir)/fonts.conf"; \
+ rm -f $(DESTDIR)$(configdir)/fonts.conf; \
+ fi; \
+ else if [ -f fonts.conf ]; then \
+ if cmp -s fonts.conf $(DESTDIR)$(configdir)/fonts.conf; then \
+ echo " uninstall standard $(DESTDIR)$(configdir)/fonts.conf"; \
+ rm -f $(DESTDIR)$(configdir)/fonts.conf; \
+ fi; \
+ fi; fi
+ if [ -f $(srcdir)/local.conf ]; then \
+ if cmp -s $(srcdir)/local.conf $(DESTDIR)$(configdir)/local.conf; then \
+ echo " uninstall standard $(DESTDIR)$(configdir)/local.conf"; \
+ rm -f $(DESTDIR)$(configdir)/local.conf; \
+ fi; \
+ else if [ -f local.conf ]; then \
+ if cmp -s local.conf $(DESTDIR)$(configdir)/local.conf; then \
+ echo " uninstall standard $(DESTDIR)$(configdir)/local.conf"; \
+ rm -f $(DESTDIR)$(configdir)/local.conf; \
+ fi; \
+ fi; fi