summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkira TAGOH <akira@tagoh.org>2017-09-06 17:01:19 +0900
committerAkira TAGOH <akira@tagoh.org>2017-11-20 17:37:22 +0530
commit7b48fd3dd406b926f0e5240b211f72197ed538a9 (patch)
treeba0155ed4c6fbebe5ffda6572c49f82380ee80e4 /configure.ac
parent64895e719dd8d18c52a31d66cd189915bc8c00b8 (diff)
downloadfontconfig-7b48fd3dd406b926f0e5240b211f72197ed538a9.tar.gz
Use uuid-based cache filename if uuid is assigned to dirs
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 71f32c1..81b433a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -339,6 +339,14 @@ LIBS="$fontconfig_save_libs"
CFLAGS="$fontconfig_save_cflags"
#
+# Check for uuid
+#
+PKG_CHECK_MODULES([UUID], [uuid])
+PKGCONFIG_REQUIRES_PRIVATELY="$PKGCONFIG_REQUIRES_PRIVATELY uuid"
+AC_SUBST(UUID_CFLAGS)
+AC_SUBST(UUID_LIBS)
+
+#
# Check expat configuration
#
AC_ARG_WITH(expat,