summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-02 02:36:24 +0100
committerAkira TAGOH <akira@tagoh.org>2022-04-12 03:59:02 +0000
commitaa681148a754384f851ab020b3f6a22def82737c (patch)
tree7511ef4670d1a40e1dc7528f9f179fa197c96573 /configure.ac
parent7dfde9b736c3405a519b570586a30d36664058af (diff)
downloadfontconfig-aa681148a754384f851ab020b3f6a22def82737c.tar.gz
configure.ac: allow disabling docbook
Sometimes we might want to build docs (install man pages, etc) but allow disabling use of docbook. Bug: https://bugs.gentoo.org/310157 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index da69f8d..2992138 100644
--- a/configure.ac
+++ b/configure.ac
@@ -736,7 +736,13 @@ dnl ===========================================================================
# Let people not build/install docs if they don't have docbook
#
-AC_CHECK_PROG(HASDOCBOOK, docbook2html, yes, no)
+AC_ARG_ENABLE(docbook,
+ [AS_HELP_STRING([--disable-docbook],
+ [Disable building docs with docbook2html (default: no)])],,)
+
+if test x$enable_docbook != xno; then
+ AC_CHECK_PROG(HASDOCBOOK, docbook2html, yes, no)
+fi
AM_CONDITIONAL(USEDOCBOOK, test "x$HASDOCBOOK" = xyes)