summaryrefslogtreecommitdiff
path: root/fc-lang/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fc-lang/Makefile.am')
-rw-r--r--fc-lang/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/fc-lang/Makefile.am b/fc-lang/Makefile.am
index 5fdccea..f8a9503 100644
--- a/fc-lang/Makefile.am
+++ b/fc-lang/Makefile.am
@@ -285,4 +285,19 @@ ORTH = \
und_zmth.orth
# ^-------------- Add new orth files here
+BUILT_SOURCES += $(top_builddir)/conf.d/35-lang-normalize.conf
+
+DISTCLEANFILES = $(BUILT_SOURCES)
+
+$(top_builddir)/conf.d/35-lang-normalize.conf: $(ORTH) Makefile
+ $(AM_V_GEN) echo "<fontconfig>" > $@ && \
+ for i in `echo $(ORTH) | sed -e 's/ /\n/g' | grep -v _ | sed -e 's/\.orth$$//g' | sort`; do \
+ echo " <!-- $$i* -> $$i -->" >> $@; \
+ echo " <match>" >> $@; \
+ echo " <test name=\"lang\" compare=\"contains\"><string>$$i</string></test>" >> $@; \
+ echo " <edit name=\"lang\" mode=\"assign\" binding=\"same\"><string>$$i</string></edit>" >> $@; \
+ echo " </match>" >> $@; \
+ done && \
+ echo "</fontconfig>" >> $@
+
-include $(top_srcdir)/git.mk