summaryrefslogtreecommitdiff
path: root/packages/Makefile.fpc.fpcmake
diff options
context:
space:
mode:
authorjonas <jonas@3ad0048d-3df7-0310-abae-a5850022a9f2>2013-11-05 20:10:55 +0000
committerjonas <jonas@3ad0048d-3df7-0310-abae-a5850022a9f2>2013-11-05 20:10:55 +0000
commit1e3512e3b8526786caee1ba35456500aa4382db2 (patch)
tree776e933a5d44f63bf338879829c7f5790884eda6 /packages/Makefile.fpc.fpcmake
parent3a90f76a76f24d9c597cf218c0c9b01162a171d5 (diff)
downloadfpc-1e3512e3b8526786caee1ba35456500aa4382db2.tar.gz
+ iosxlocale unit that uses CoreFoundation to fill in the sysutils locale
settings on (Mac) OS X and iOS (implementation by Yury Sidorov, mantis #18528) git-svn-id: http://svn.freepascal.org/svn/fpc/trunk@25941 3ad0048d-3df7-0310-abae-a5850022a9f2
Diffstat (limited to 'packages/Makefile.fpc.fpcmake')
-rw-r--r--packages/Makefile.fpc.fpcmake12
1 files changed, 10 insertions, 2 deletions
diff --git a/packages/Makefile.fpc.fpcmake b/packages/Makefile.fpc.fpcmake
index 268e03f802..88744edf98 100644
--- a/packages/Makefile.fpc.fpcmake
+++ b/packages/Makefile.fpc.fpcmake
@@ -26,9 +26,9 @@ dirs_freebsd=fv fcl-web fastcgi fcl-async ibase mysql ncurses zlib oracle odbc p
imlib utmp fpgtk xforms fftw pcap ggi sdl openssl graph gnome1 gtk1 gtk2 librsvg httpd22 pxlib numlib \
users iconvenc gmp fcl-extra libxml
dirs_darwin=fv fcl-web fastcgi fcl-async ibase mysql ncurses zlib oracle odbc postgres sqlite pthreads imagemagick \
- libpng gdbm tcl syslog libcurl bfd aspell utmp fftw pcap openssl numlib iconvenc gmp fcl-extra univint
+ libpng gdbm tcl syslog libcurl bfd aspell utmp fftw pcap openssl numlib iconvenc gmp fcl-extra univint iosxlocale
dirs_iphonesim=fv fcl-web fastcgi fcl-async ibase mysql ncurses zlib oracle odbc postgres sqlite pthreads imagemagick \
- libpng gdbm tcl syslog libcurl bfd aspell utmp fftw pcap openssl numlib iconvenc gmp fcl-extra univint
+ libpng gdbm tcl syslog libcurl bfd aspell utmp fftw pcap openssl numlib iconvenc gmp fcl-extra univint iosxlocale
dirs_i386_darwin=graph sdl opengl x11 cairo gtk1 gtk2 librsvg fpgtk xforms gnome1 httpd22 imlib objcrtl cocoaint opencl openal
dirs_powerpc_darwin=graph sdl opengl x11 cairo gtk1 gtk2 librsvg fpgtk xforms gnome1 httpd22 imlib objcrtl cocoaint
dirs_x86_64_darwin=opengl x11 cairo gtk1 gtk2 librsvg fpgtk xforms gnome1 httpd22 imlib cocoaint objcrtl
@@ -144,6 +144,14 @@ cocoaint_release: univint_release
cocoaint_shared: univint_shared
endif
+ifneq ($(findstring $(OS_TARGET),darwin iphonesim),)
+iosxlocale_all: univint_all
+iosxlocale_debug: univint_debug
+iosxlocale_smart: univint_smart
+iosxlocale_release: univint_release
+iosxlocle_shared: univint_shared
+endif
+
ifneq ($(findstring $(OS_TARGET),beos haiku freebsd darwin iphonesim solaris netbsd openbsd linux win32 win64 wince),)
fppkg_all: fpmkunit_all fcl-base_all fcl-xml_all fcl-process_all fcl-net_all paszlib_all fcl-web_all fpmkunit_all
fppkg_debug: fpmkunit_debug fcl-base_debug fcl-xml_debug fcl-process_debug fcl-net_debug paszlib_debug fcl-web_debug fpmkunit_debug