summaryrefslogtreecommitdiff
path: root/packages/cairo
diff options
context:
space:
mode:
authormarco <marco@3ad0048d-3df7-0310-abae-a5850022a9f2>2015-01-04 21:09:04 +0000
committermarco <marco@3ad0048d-3df7-0310-abae-a5850022a9f2>2015-01-04 21:09:04 +0000
commit5a37208bab29adcd0aed1ba16f53834824a98c93 (patch)
treedf9e48496dbe486e5c5655cceeaf4ecd1c9f4dfe /packages/cairo
parentdf3550bfb36465282344ab23c80eef4c78f9b3fc (diff)
downloadfpc-5a37208bab29adcd0aed1ba16f53834824a98c93.tar.gz
* version updated to 3.1.1
git-svn-id: http://svn.freepascal.org/svn/fpc/trunk@29399 3ad0048d-3df7-0310-abae-a5850022a9f2
Diffstat (limited to 'packages/cairo')
-rw-r--r--packages/cairo/Makefile24
-rw-r--r--packages/cairo/Makefile.fpc2
-rw-r--r--packages/cairo/Makefile.fpc.fpcmake2
-rw-r--r--packages/cairo/fpmake.pp2
4 files changed, 22 insertions, 8 deletions
diff --git a/packages/cairo/Makefile b/packages/cairo/Makefile
index 1860d46f50..bc5afb93a3 100644
--- a/packages/cairo/Makefile
+++ b/packages/cairo/Makefile
@@ -1,9 +1,9 @@
#
-# Don't edit, this file is generated by FPCMake Version 2.0.0 [2014-08-17 rev 28432]
+# Don't edit, this file is generated by FPCMake Version 2.0.0 [2014-12-07 rev 29213]
#
default: all
-MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-haiku i386-netbsd i386-solaris i386-qnx i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian i386-nativent i386-iphonesim i386-android i386-aros m68k-linux m68k-freebsd m68k-netbsd m68k-amiga m68k-atari m68k-openbsd m68k-palmos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded powerpc-wii powerpc-aix sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-netbsd x86_64-solaris x86_64-openbsd x86_64-darwin x86_64-win64 x86_64-embedded arm-linux arm-palmos arm-darwin arm-wince arm-gba arm-nds arm-embedded arm-symbian arm-android powerpc64-linux powerpc64-darwin powerpc64-embedded powerpc64-aix avr-embedded armeb-linux armeb-embedded mips-linux mipsel-linux mipsel-embedded mipsel-android jvm-java jvm-android i8086-msdos
-BSDs = freebsd netbsd openbsd darwin
+MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-haiku i386-netbsd i386-solaris i386-qnx i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian i386-nativent i386-iphonesim i386-android i386-aros m68k-linux m68k-freebsd m68k-netbsd m68k-amiga m68k-atari m68k-openbsd m68k-palmos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded powerpc-wii powerpc-aix sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-netbsd x86_64-solaris x86_64-openbsd x86_64-darwin x86_64-win64 x86_64-embedded x86_64-dragonfly arm-linux arm-palmos arm-darwin arm-wince arm-gba arm-nds arm-embedded arm-symbian arm-android powerpc64-linux powerpc64-darwin powerpc64-embedded powerpc64-aix avr-embedded armeb-linux armeb-embedded mips-linux mipsel-linux mipsel-embedded mipsel-android jvm-java jvm-android i8086-msdos
+BSDs = freebsd netbsd openbsd darwin dragonfly
UNIXs = linux $(BSDs) solaris qnx haiku aix
LIMIT83fs = go32v2 os2 emx watcom msdos
OSNeedsComspecToRunBatch = go32v2 watcom
@@ -326,7 +326,7 @@ FPCFPMAKE=$(FPC)
endif
endif
override PACKAGE_NAME=cairo
-override PACKAGE_VERSION=2.7.1
+override PACKAGE_VERSION=3.1.1
FPMAKE_BIN_CLEAN=$(wildcard ./fpmake$(SRCEXEEXT))
ifdef OS_TARGET
FPC_TARGETOPT+=--os=$(OS_TARGET)
@@ -578,6 +578,12 @@ EXEEXT=
HASSHAREDLIB=1
SHORTSUFFIX=lnx
endif
+ifeq ($(OS_TARGET),dragonfly)
+BATCHEXT=.sh
+EXEEXT=
+HASSHAREDLIB=1
+SHORTSUFFIX=df
+endif
ifeq ($(OS_TARGET),freebsd)
BATCHEXT=.sh
EXEEXT=
@@ -1404,6 +1410,14 @@ REQUIRE_PACKAGES_HASH=1
REQUIRE_PACKAGES_LIBTAR=1
REQUIRE_PACKAGES_FPMKUNIT=1
endif
+ifeq ($(FULL_TARGET),x86_64-dragonfly)
+REQUIRE_PACKAGES_RTL=1
+REQUIRE_PACKAGES_PASZLIB=1
+REQUIRE_PACKAGES_FCL-PROCESS=1
+REQUIRE_PACKAGES_HASH=1
+REQUIRE_PACKAGES_LIBTAR=1
+REQUIRE_PACKAGES_FPMKUNIT=1
+endif
ifeq ($(FULL_TARGET),arm-linux)
REQUIRE_PACKAGES_RTL=1
REQUIRE_PACKAGES_PASZLIB=1
@@ -1929,7 +1943,7 @@ endif
ifdef CREATESHARED
override FPCOPT+=-Cg
endif
-ifneq ($(findstring $(OS_TARGET),freebsd openbsd netbsd linux solaris),)
+ifneq ($(findstring $(OS_TARGET),dragonfly freebsd openbsd netbsd linux solaris),)
ifeq ($(CPU_TARGET),x86_64)
override FPCOPT+=-Cg
endif
diff --git a/packages/cairo/Makefile.fpc b/packages/cairo/Makefile.fpc
index 70bd318b79..871d13863f 100644
--- a/packages/cairo/Makefile.fpc
+++ b/packages/cairo/Makefile.fpc
@@ -4,7 +4,7 @@
[package]
name=cairo
-version=2.7.1
+version=3.1.1
[require]
packages=rtl fpmkunit
diff --git a/packages/cairo/Makefile.fpc.fpcmake b/packages/cairo/Makefile.fpc.fpcmake
index 3128103f95..4108236e5a 100644
--- a/packages/cairo/Makefile.fpc.fpcmake
+++ b/packages/cairo/Makefile.fpc.fpcmake
@@ -16,7 +16,7 @@ packages_iphonesim=x11
[package]
name=cairo
-version=2.7.1
+version=3.1.1
[target]
units=cairo cairoft
diff --git a/packages/cairo/fpmake.pp b/packages/cairo/fpmake.pp
index d52ed379a1..b9648ab615 100644
--- a/packages/cairo/fpmake.pp
+++ b/packages/cairo/fpmake.pp
@@ -15,7 +15,7 @@ begin
{$ifdef ALLPACKAGES}
P.Directory:=ADirectory;
{$endif ALLPACKAGES}
- P.Version:='2.7.1';
+ P.Version:='3.1.1';
P.Author := 'Library: University of Southern California + Red Hat Inc., header: Luiz AmXrico Pereira CXmara';
P.License := 'Library: MPL 1.1 + LGPL-2.1, header: LGPL with modification, ';
P.HomepageURL := 'www.freepascal.org';