summaryrefslogtreecommitdiff
path: root/packages/extra/gtk/gtkgl/Makefile
diff options
context:
space:
mode:
authortom_at_work <tom_at_work@3ad0048d-3df7-0310-abae-a5850022a9f2>2005-10-20 16:56:40 +0000
committertom_at_work <tom_at_work@3ad0048d-3df7-0310-abae-a5850022a9f2>2005-10-20 16:56:40 +0000
commite481c1bbbb58c85fbc2f10f35bace0e9fa1472d6 (patch)
treead103e10ae3ce49abfcc474a040d657d86c1ffa1 /packages/extra/gtk/gtkgl/Makefile
parentcd9efa713a3f2596ea936eca6f3e9684dea93d00 (diff)
downloadfpc-e481c1bbbb58c85fbc2f10f35bace0e9fa1472d6.tar.gz
* fpcmake.ini update which fixes glibc search path problems on PowerPC64
* makefile update git-svn-id: http://svn.freepascal.org/svn/fpc/trunk@1546 3ad0048d-3df7-0310-abae-a5850022a9f2
Diffstat (limited to 'packages/extra/gtk/gtkgl/Makefile')
-rw-r--r--packages/extra/gtk/gtkgl/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/packages/extra/gtk/gtkgl/Makefile b/packages/extra/gtk/gtkgl/Makefile
index 0351f50606..e638f4d699 100644
--- a/packages/extra/gtk/gtkgl/Makefile
+++ b/packages/extra/gtk/gtkgl/Makefile
@@ -1,5 +1,5 @@
#
-# Don't edit, this file is generated by FPCMake Version 2.0.0 [2005/10/15]
+# Don't edit, this file is generated by FPCMake Version 2.0.0 [2005/10/20]
#
default: all
MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-netbsd i386-solaris i386-qnx i386-netware i386-openbsd i386-wdosx i386-emx i386-watcom i386-netwlibc i386-wince m68k-linux m68k-freebsd m68k-netbsd m68k-amiga m68k-atari m68k-openbsd m68k-palmos powerpc-linux powerpc-netbsd powerpc-macos powerpc-darwin powerpc-morphos sparc-linux sparc-netbsd sparc-solaris x86_64-linux x86_64-freebsd x86_64-win64 arm-linux arm-wince powerpc64-linux
@@ -657,6 +657,11 @@ GCCLIBDIR:=$(shell dirname `gcc -m32 -print-libgcc-file-name`)
endif
endif
endif
+ifeq ($(CPU_TARGET),powerpc64)
+ifeq ($(BINUTILSPREFIX),)
+GCCLIBDIR:=$(shell dirname `gcc -m64 -print-libgcc-file-name`)
+endif
+endif
endif
ifndef GCCLIBDIR
CROSSGCC=$(strip $(wildcard $(addsuffix /$(BINUTILSPREFIX)gcc$(SRCEXEEXT),$(SEARCHPATH))))