summaryrefslogtreecommitdiff
path: root/packages/extra/oggvorbis
diff options
context:
space:
mode:
authorpeter <peter@3ad0048d-3df7-0310-abae-a5850022a9f2>2007-10-29 09:07:18 +0000
committerpeter <peter@3ad0048d-3df7-0310-abae-a5850022a9f2>2007-10-29 09:07:18 +0000
commitae610c076a4c50cc48afd764e73cf7f4c098cc6a (patch)
tree37808c12d047c3038d02c515c6bc7d8323542cbc /packages/extra/oggvorbis
parent7f8f23b06cee6fbc79a4ebe8556a1eb97072da49 (diff)
downloadfpc-ae610c076a4c50cc48afd764e73cf7f4c098cc6a.tar.gz
* regenerated to update dependencies
git-svn-id: http://svn.freepascal.org/svn/fpc/trunk@8988 3ad0048d-3df7-0310-abae-a5850022a9f2
Diffstat (limited to 'packages/extra/oggvorbis')
-rw-r--r--packages/extra/oggvorbis/Makefile20
1 files changed, 17 insertions, 3 deletions
diff --git a/packages/extra/oggvorbis/Makefile b/packages/extra/oggvorbis/Makefile
index 0eef2c07c1..f4e44dca2a 100644
--- a/packages/extra/oggvorbis/Makefile
+++ b/packages/extra/oggvorbis/Makefile
@@ -1,11 +1,12 @@
#
-# Don't edit, this file is generated by FPCMake Version 2.0.0 [2007/08/22]
+# Don't edit, this file is generated by FPCMake Version 2.0.0 [2007/10/29]
#
default: all
MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-netbsd i386-solaris i386-qnx i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian m68k-linux m68k-freebsd m68k-netbsd m68k-amiga m68k-atari m68k-openbsd m68k-palmos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-win64 x86_64-embedded arm-linux arm-palmos arm-wince arm-gba arm-nds arm-embedded arm-symbian powerpc64-linux powerpc64-darwin powerpc64-embedded
BSDs = freebsd netbsd openbsd darwin
UNIXs = linux $(BSDs) solaris qnx
LIMIT83fs = go32v2 os2 emx watcom
+OSNeedsComspecToRunBatch = go32v2 watcom
FORCE:
.PHONY: FORCE
override PATH:=$(patsubst %/,%,$(subst \,/,$(PATH)))
@@ -56,6 +57,11 @@ else
SRCBATCHEXT=.bat
endif
endif
+ifdef COMSPEC
+ifneq ($(findstring $(OS_SOURCE),$(OSNeedsComspecToRunBatch)),)
+RUNBATCH=$(COMSPEC) /C
+endif
+endif
ifdef inUnix
PATHSEP=/
else
@@ -102,7 +108,7 @@ ifndef FPC
FPCPROG:=$(strip $(wildcard $(addsuffix /fpc$(SRCEXEEXT),$(SEARCHPATH))))
ifneq ($(FPCPROG),)
FPCPROG:=$(firstword $(FPCPROG))
-FPC:=$(shell $(FPCPROG) -PB)
+FPC:=$(shell $(FPCPROG) -P$(CPU_TARGET) -PB)
ifneq ($(findstring Error,$(FPC)),)
override FPC=$(firstword $(strip $(wildcard $(addsuffix /ppc386$(SRCEXEEXT),$(SEARCHPATH)))))
endif
@@ -1333,7 +1339,7 @@ override FPCOPT+=-FD$(NEW_BINUTILS_PATH)
endif
ifndef CROSSBOOTSTRAP
ifneq ($(BINUTILSPREFIX),)
-override FPCOPT+=-XP$(BINUTILSPREFIX)
+override FPCOPT+=-XP$(BINUTILSPREFIX)
endif
ifneq ($(BINUTILSPREFIX),)
override FPCOPT+=-Xr$(RLINKPATH)
@@ -1465,9 +1471,13 @@ ifeq (,$(findstring -s ,$(COMPILER)))
EXECPPAS=
else
ifeq ($(FULL_SOURCE),$(FULL_TARGET))
+ifdef RUNBATCH
+EXECPPAS:=@$(RUNBATCH) $(PPAS)
+else
EXECPPAS:=@$(PPAS)
endif
endif
+endif
.PHONY: fpc_units
ifneq ($(TARGET_UNITS),)
override ALLTARGET+=fpc_units
@@ -1692,8 +1702,12 @@ endif
ifdef inUnix
/bin/sh $(ZIPWRAPPER)
else
+ifdef RUNBATCH
+ $(RUNBATCH) (ZIPWRAPPER)
+else
$(ZIPWRAPPER)
endif
+endif
$(DEL) $(ZIPWRAPPER)
else
$(ZIPCMD_CDPACK) ; $(ZIPCMD_ZIP) ; $(ZIPCMD_CDBASE)