summaryrefslogtreecommitdiff
path: root/packages/extra/ptc
diff options
context:
space:
mode:
authorjonas <jonas@3ad0048d-3df7-0310-abae-a5850022a9f2>2007-01-27 11:05:18 +0000
committerjonas <jonas@3ad0048d-3df7-0310-abae-a5850022a9f2>2007-01-27 11:05:18 +0000
commit5357aed6c2ae1d3ff0e621b99e8e42d7dc87625c (patch)
tree4667a26282ed81af97b566f1dc85cb2664bb55df /packages/extra/ptc
parent1fdeaece2b827fc1841dd3df4a5d8fa731944fa6 (diff)
downloadfpc-5357aed6c2ae1d3ff0e621b99e8e42d7dc87625c.tar.gz
+ support for make -jX by marking all Makefiles that need to be executed
serially with .NOTPARALLEL: -> currently parallel: rtl/darwin, packages/base, packages/base/httpd, packages/extra/univint, fcl, utils git-svn-id: http://svn.freepascal.org/svn/fpc/trunk@6223 3ad0048d-3df7-0310-abae-a5850022a9f2
Diffstat (limited to 'packages/extra/ptc')
-rw-r--r--packages/extra/ptc/Makefile.fpc3
-rw-r--r--packages/extra/ptc/demos/Makefile.fpc3
-rw-r--r--packages/extra/ptc/examples/Makefile.fpc3
3 files changed, 9 insertions, 0 deletions
diff --git a/packages/extra/ptc/Makefile.fpc b/packages/extra/ptc/Makefile.fpc
index cae963dcc5..6102642e72 100644
--- a/packages/extra/ptc/Makefile.fpc
+++ b/packages/extra/ptc/Makefile.fpc
@@ -24,3 +24,6 @@ packages_freebsd=x11
[default]
fpcdir=../../..
+
+[rules]
+.NOTPARALLEL:
diff --git a/packages/extra/ptc/demos/Makefile.fpc b/packages/extra/ptc/demos/Makefile.fpc
index 2208629736..0f1d469867 100644
--- a/packages/extra/ptc/demos/Makefile.fpc
+++ b/packages/extra/ptc/demos/Makefile.fpc
@@ -19,3 +19,6 @@ fpcdir=../../../..
packages=hermes ptc
packages_linux=x11
packages_freebsd=x11
+
+[rules]
+.NOTPARALLEL:
diff --git a/packages/extra/ptc/examples/Makefile.fpc b/packages/extra/ptc/examples/Makefile.fpc
index e5c8b621a3..5301f107bb 100644
--- a/packages/extra/ptc/examples/Makefile.fpc
+++ b/packages/extra/ptc/examples/Makefile.fpc
@@ -20,3 +20,6 @@ fpcdir=../../../..
packages=hermes ptc
packages_linux=x11
packages_freebsd=x11
+
+[rules]
+.NOTPARALLEL: