summaryrefslogtreecommitdiff
path: root/packages/fcl-extra
diff options
context:
space:
mode:
authorjoost <joost@3ad0048d-3df7-0310-abae-a5850022a9f2>2011-08-06 22:52:41 +0000
committerjoost <joost@3ad0048d-3df7-0310-abae-a5850022a9f2>2011-08-06 22:52:41 +0000
commit8b32da9fc6168e53e9c302c035d6c5d9df1bf803 (patch)
tree1e67a852dcccf5499008a311716d50b5069d223c /packages/fcl-extra
parentd21bd83a0c25988e160248b7fbe0b59ce68f5f6c (diff)
downloadfpc-8b32da9fc6168e53e9c302c035d6c5d9df1bf803.tar.gz
* Use fpc_cleanall instead of fpc_distclean on a make distclean when no fpmake-binary is available. Because fpc_cleanall could be an empty target
git-svn-id: http://svn.freepascal.org/svn/fpc/trunk@18128 3ad0048d-3df7-0310-abae-a5850022a9f2
Diffstat (limited to 'packages/fcl-extra')
-rw-r--r--packages/fcl-extra/Makefile2
-rw-r--r--packages/fcl-extra/Makefile.fpc2
2 files changed, 2 insertions, 2 deletions
diff --git a/packages/fcl-extra/Makefile b/packages/fcl-extra/Makefile
index 109d75ffb2..546a466acb 100644
--- a/packages/fcl-extra/Makefile
+++ b/packages/fcl-extra/Makefile
@@ -2232,7 +2232,7 @@ clean:
$(FPMAKE_BIN_CLEAN) clean --localunitdir=../.. --globalunitdir=.. $(FPC_TARGETOPT) $(addprefix -o ,$(FPCOPT)) --compiler=$(FPC)
endif
ifeq ($(FPMAKE_BIN_CLEAN),)
-distclean: $(addsuffix _distclean,$(TARGET_DIRS)) fpc_distclean
+distclean: $(addsuffix _distclean,$(TARGET_DIRS)) fpc_cleanall
else
distclean:
ifdef inUnix
diff --git a/packages/fcl-extra/Makefile.fpc b/packages/fcl-extra/Makefile.fpc
index 4715cdf9a7..ad172b7000 100644
--- a/packages/fcl-extra/Makefile.fpc
+++ b/packages/fcl-extra/Makefile.fpc
@@ -48,7 +48,7 @@ endif
# In case of a distclean, perform an 'old'-style distclean. This to avoid problems
# when the package is compiled using fpcmake prior to running this clean using fpmake
ifeq ($(FPMAKE_BIN_CLEAN),)
-distclean: $(addsuffix _distclean,$(TARGET_DIRS)) fpc_distclean
+distclean: $(addsuffix _distclean,$(TARGET_DIRS)) fpc_cleanall
else
distclean:
ifdef inUnix