summaryrefslogtreecommitdiff
path: root/packages/fpmkunit/Makefile.fpc
diff options
context:
space:
mode:
authorjoost <joost@3ad0048d-3df7-0310-abae-a5850022a9f2>2011-04-26 21:06:25 +0000
committerjoost <joost@3ad0048d-3df7-0310-abae-a5850022a9f2>2011-04-26 21:06:25 +0000
commitd3c37ac144e6881e4a7d5061c0d84aa10e9fe60e (patch)
tree1b8ddfe5ef98bc123cf7030488ee8aebd4a942da /packages/fpmkunit/Makefile.fpc
parent6db7d4d49f78c7e01aeff11075afe289a15ca379 (diff)
downloadfpc-d3c37ac144e6881e4a7d5061c0d84aa10e9fe60e.tar.gz
* Bootstrap native version of fpmkunit when cross-compiling
git-svn-id: http://svn.freepascal.org/svn/fpc/trunk@17375 3ad0048d-3df7-0310-abae-a5850022a9f2
Diffstat (limited to 'packages/fpmkunit/Makefile.fpc')
-rw-r--r--packages/fpmkunit/Makefile.fpc12
1 files changed, 12 insertions, 0 deletions
diff --git a/packages/fpmkunit/Makefile.fpc b/packages/fpmkunit/Makefile.fpc
index 61286c1222..36ec428082 100644
--- a/packages/fpmkunit/Makefile.fpc
+++ b/packages/fpmkunit/Makefile.fpc
@@ -22,5 +22,17 @@ includedir=src
[default]
fpcdir=../..
+[prerules]
+TARGET_UNITDIRBS=units_bs/$(SOURCESUFFIX)
+CLEAN_FILES+=units_bs/$(SOURCESUFFIX)/fpmkunit.ppu units_bs/$(SOURCESUFFIX)/fpmkunit.rst units_bs/$(SOURCESUFFIX)/fpmkunit.o
+
[rules]
.NOTPARALLEL:
+
+$(TARGET_UNITDIRBS):
+ $(MKDIRTREE) $(TARGET_UNITDIRBS)
+bootstrap: $(TARGET_UNITDIRBS)
+ $(FPCFPMAKE) src/fpmkunit.pp -n $(addprefix -Fu,$(COMPILER_FPMAKE_UNITDIR)) -dNO_UNIT_PROCESS -dNO_UNIT_ZIPPER -FU$(TARGET_UNITDIRBS)
+cleanall: fpc_cleanall
+ -$(DELTREE) units_bs
+