summaryrefslogtreecommitdiff
path: root/packages/libndsfpc/examples/ds_motion
diff options
context:
space:
mode:
authorjonas <jonas@3ad0048d-3df7-0310-abae-a5850022a9f2>2012-04-11 18:03:57 +0000
committerjonas <jonas@3ad0048d-3df7-0310-abae-a5850022a9f2>2012-04-11 18:03:57 +0000
commit6a781df311485cc0ce5f0b66359c345c3fffaf63 (patch)
tree57e7c6bad48b233195024329439ee89494e72519 /packages/libndsfpc/examples/ds_motion
parent21f926fd5dbf0de9bc9d9b88635516988bd2cfd4 (diff)
downloadfpc-6a781df311485cc0ce5f0b66359c345c3fffaf63.tar.gz
* regenerated Makefiles with AIX support
git-svn-id: http://svn.freepascal.org/svn/fpc/trunk@20812 3ad0048d-3df7-0310-abae-a5850022a9f2
Diffstat (limited to 'packages/libndsfpc/examples/ds_motion')
-rw-r--r--packages/libndsfpc/examples/ds_motion/Makefile45
1 files changed, 42 insertions, 3 deletions
diff --git a/packages/libndsfpc/examples/ds_motion/Makefile b/packages/libndsfpc/examples/ds_motion/Makefile
index 82be9e6a25..787ad0ba19 100644
--- a/packages/libndsfpc/examples/ds_motion/Makefile
+++ b/packages/libndsfpc/examples/ds_motion/Makefile
@@ -1,10 +1,10 @@
#
-# Don't edit, this file is generated by FPCMake Version 2.0.0 [2012/04/05]
+# Don't edit, this file is generated by FPCMake Version 2.0.0 [2012/04/11]
#
default: all
-MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-haiku i386-netbsd i386-solaris i386-qnx i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian i386-nativent i386-iphonesim m68k-linux m68k-freebsd m68k-netbsd m68k-amiga m68k-atari m68k-openbsd m68k-palmos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded powerpc-wii sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-solaris x86_64-openbsd x86_64-darwin x86_64-win64 x86_64-embedded arm-linux arm-palmos arm-darwin arm-wince arm-gba arm-nds arm-embedded arm-symbian powerpc64-linux powerpc64-darwin powerpc64-embedded avr-embedded armeb-linux armeb-embedded mips-linux mipsel-linux
+MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-haiku i386-netbsd i386-solaris i386-qnx i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian i386-nativent i386-iphonesim m68k-linux m68k-freebsd m68k-netbsd m68k-amiga m68k-atari m68k-openbsd m68k-palmos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded powerpc-wii powerpc-aix sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-solaris x86_64-openbsd x86_64-darwin x86_64-win64 x86_64-embedded arm-linux arm-palmos arm-darwin arm-wince arm-gba arm-nds arm-embedded arm-symbian powerpc64-linux powerpc64-darwin powerpc64-embedded powerpc64-aix avr-embedded armeb-linux armeb-embedded mips-linux mipsel-linux
BSDs = freebsd netbsd openbsd darwin
-UNIXs = linux $(BSDs) solaris qnx haiku
+UNIXs = linux $(BSDs) solaris qnx haiku aix
LIMIT83fs = go32v2 os2 emx watcom
OSNeedsComspecToRunBatch = go32v2 watcom
FORCE:
@@ -411,6 +411,9 @@ endif
ifeq ($(FULL_TARGET),powerpc-wii)
override TARGET_PROGRAMS+=dsMotion
endif
+ifeq ($(FULL_TARGET),powerpc-aix)
+override TARGET_PROGRAMS+=dsMotion
+endif
ifeq ($(FULL_TARGET),sparc-linux)
override TARGET_PROGRAMS+=dsMotion
endif
@@ -477,6 +480,9 @@ endif
ifeq ($(FULL_TARGET),powerpc64-embedded)
override TARGET_PROGRAMS+=dsMotion
endif
+ifeq ($(FULL_TARGET),powerpc64-aix)
+override TARGET_PROGRAMS+=dsMotion
+endif
ifeq ($(FULL_TARGET),avr-embedded)
override TARGET_PROGRAMS+=dsMotion
endif
@@ -606,6 +612,9 @@ endif
ifeq ($(FULL_TARGET),powerpc-wii)
override CLEAN_UNITS+=*
endif
+ifeq ($(FULL_TARGET),powerpc-aix)
+override CLEAN_UNITS+=*
+endif
ifeq ($(FULL_TARGET),sparc-linux)
override CLEAN_UNITS+=*
endif
@@ -672,6 +681,9 @@ endif
ifeq ($(FULL_TARGET),powerpc64-embedded)
override CLEAN_UNITS+=*
endif
+ifeq ($(FULL_TARGET),powerpc64-aix)
+override CLEAN_UNITS+=*
+endif
ifeq ($(FULL_TARGET),avr-embedded)
override CLEAN_UNITS+=*
endif
@@ -801,6 +813,9 @@ endif
ifeq ($(FULL_TARGET),powerpc-wii)
override CLEAN_FILES+=*.elf *.o *.s *.nds *.nef *.h *.bin $(BUILD)/*
endif
+ifeq ($(FULL_TARGET),powerpc-aix)
+override CLEAN_FILES+=*.elf *.o *.s *.nds *.nef *.h *.bin $(BUILD)/*
+endif
ifeq ($(FULL_TARGET),sparc-linux)
override CLEAN_FILES+=*.elf *.o *.s *.nds *.nef *.h *.bin $(BUILD)/*
endif
@@ -867,6 +882,9 @@ endif
ifeq ($(FULL_TARGET),powerpc64-embedded)
override CLEAN_FILES+=*.elf *.o *.s *.nds *.nef *.h *.bin $(BUILD)/*
endif
+ifeq ($(FULL_TARGET),powerpc64-aix)
+override CLEAN_FILES+=*.elf *.o *.s *.nds *.nef *.h *.bin $(BUILD)/*
+endif
ifeq ($(FULL_TARGET),avr-embedded)
override CLEAN_FILES+=*.elf *.o *.s *.nds *.nef *.h *.bin $(BUILD)/*
endif
@@ -1235,6 +1253,11 @@ EXEEXT=.dol
SHAREDLIBEXT=.so
SHORTSUFFIX=wii
endif
+ifeq ($(OS_TARGET),aix)
+BATCHEXT=.sh
+EXEEXT=
+SHORTSUFFIX=aix
+endif
ifneq ($(findstring $(OS_SOURCE),$(LIMIT83fs)),)
FPCMADE=fpcmade.$(SHORTSUFFIX)
ZIPSUFFIX=$(SHORTSUFFIX)
@@ -1781,6 +1804,14 @@ REQUIRE_PACKAGES_HASH=1
REQUIRE_PACKAGES_FPMKUNIT=1
REQUIRE_PACKAGES_LIBNDSFPC=1
endif
+ifeq ($(FULL_TARGET),powerpc-aix)
+REQUIRE_PACKAGES_RTL=1
+REQUIRE_PACKAGES_PASZLIB=1
+REQUIRE_PACKAGES_FCL-PROCESS=1
+REQUIRE_PACKAGES_HASH=1
+REQUIRE_PACKAGES_FPMKUNIT=1
+REQUIRE_PACKAGES_LIBNDSFPC=1
+endif
ifeq ($(FULL_TARGET),sparc-linux)
REQUIRE_PACKAGES_RTL=1
REQUIRE_PACKAGES_PASZLIB=1
@@ -1957,6 +1988,14 @@ REQUIRE_PACKAGES_HASH=1
REQUIRE_PACKAGES_FPMKUNIT=1
REQUIRE_PACKAGES_LIBNDSFPC=1
endif
+ifeq ($(FULL_TARGET),powerpc64-aix)
+REQUIRE_PACKAGES_RTL=1
+REQUIRE_PACKAGES_PASZLIB=1
+REQUIRE_PACKAGES_FCL-PROCESS=1
+REQUIRE_PACKAGES_HASH=1
+REQUIRE_PACKAGES_FPMKUNIT=1
+REQUIRE_PACKAGES_LIBNDSFPC=1
+endif
ifeq ($(FULL_TARGET),avr-embedded)
REQUIRE_PACKAGES_RTL=1
REQUIRE_PACKAGES_PASZLIB=1