summaryrefslogtreecommitdiff
path: root/packages/os4units
diff options
context:
space:
mode:
authornickysn <nickysn@3ad0048d-3df7-0310-abae-a5850022a9f2>2021-03-13 21:47:24 +0000
committernickysn <nickysn@3ad0048d-3df7-0310-abae-a5850022a9f2>2021-03-13 21:47:24 +0000
commitaed7424e21332198b9d11fa3ce1071a796a9e187 (patch)
treeefd91efb76959c74f5f9a55b36118a17cb8a0213 /packages/os4units
parent62c237e276fb82d4b6f2ea98b9c0014279cda9b7 (diff)
parentf4b984d2356cc47030adc7378858c428a399a589 (diff)
downloadfpc-aed7424e21332198b9d11fa3ce1071a796a9e187.tar.gz
* synchronized with trunk
git-svn-id: https://svn.freepascal.org/svn/fpc/branches/wasm@48949 3ad0048d-3df7-0310-abae-a5850022a9f2
Diffstat (limited to 'packages/os4units')
-rw-r--r--packages/os4units/Makefile8
-rw-r--r--packages/os4units/src/cybergraphics.pas18
2 files changed, 20 insertions, 6 deletions
diff --git a/packages/os4units/Makefile b/packages/os4units/Makefile
index 523fbb89cc..ee70199133 100644
--- a/packages/os4units/Makefile
+++ b/packages/os4units/Makefile
@@ -607,10 +607,18 @@ else
ifneq ($(findstring $(FPCFPMAKE_CPU_OPT),mips mipsel),)
FPCMAKE_CROSSGCCOPT=-mabi=32
else
+ifneq ($(findstring $(FPCFPMAKE_CPU_OPT),riscv64),)
+FPCMAKE_CROSSGCCOPT=-mabi=lp64
+else
+ifneq ($(findstring $(FPCFPMAKE_CPU_OPT),riscv32),)
+FPCMAKE_CROSSGCCOPT=-mabi=ilp32
+else
FPCMAKE_CROSSGCCOPT=-m32
endif
endif
endif
+endif
+endif
FPCMAKEGCCLIBDIR:=$(shell dirname `gcc $(FPCMAKE_CROSSGCCOPT) -print-libgcc-file-name`)
endif
endif
diff --git a/packages/os4units/src/cybergraphics.pas b/packages/os4units/src/cybergraphics.pas
index 995dcef99a..6d4155cc2e 100644
--- a/packages/os4units/src/cybergraphics.pas
+++ b/packages/os4units/src/cybergraphics.pas
@@ -189,12 +189,13 @@ function WritePixelArrayAlpha(Src: APTR; SrcX, SrcY, SrcMod: LongInt; Rp: PRastP
procedure BltTemplateAlpha(SrcTemplate: APTR; SrcX, SrcY: LongInt; Rp: PRastPort; DestX, DestY: LongInt; Width, Height: LongWord); syscall ICyberGfx 232;
// Functions and procedures with array of const go here
-function AllocCModeListTags(const ModeListTags: array of PtrUInt): PList;
-function BestCModeIDTags(const BestModeIDTags: array of PtrUInt): LongWord;
-procedure CVideoCtrlTags(ViewPort: PViewPort; const TagList: array of PtrUInt);
-procedure DoCDrawMethodTags(Hook: PHook; a1arg: PRastPort; const TagList: array of PtrUInt);
-function LockBitMapTags(BitMap: APTR; const TagList: array of PtrUInt): APTR;
-procedure UnLockBitMapTags(Handle: APTR; const TagList: array of PtrUInt);
+function AllocCModeListTags(const ModeListTags: array of PtrUInt): PList; inline;
+function BestCModeIDTags(const BestModeIDTags: array of PtrUInt): LongWord; inline;
+function CModeRequestTags(ModeRequest: APTR; const ModeRequestTags : array of PtrUInt): LongWord; inline;
+procedure CVideoCtrlTags(ViewPort: PViewPort; const TagList: array of PtrUInt); inline;
+procedure DoCDrawMethodTags(Hook: PHook; a1arg: PRastPort; const TagList: array of PtrUInt); inline;
+function LockBitMapTags(BitMap: APTR; const TagList: array of PtrUInt): APTR; inline;
+procedure UnLockBitMapTags(Handle: APTR; const TagList: array of PtrUInt); inline;
function SHIFT_PIXFMT(fmt: LongInt): LongInt;
function DOWNSHIFT_PIXFMT(fmt: LongInt): LongInt;
@@ -212,6 +213,11 @@ begin
BestCModeIDTags := BestCModeIDTagList(@BestModeIDTags);
end;
+function CModeRequestTags(ModeRequest: APTR; const ModeRequestTags : array of PtrUInt): LongWord;
+begin
+ CModeRequestTags := CModeRequestTagList(ModeRequest, @ModeRequestTags);
+end;
+
procedure CVideoCtrlTags(ViewPort: PViewPort; const TagList: array of PtrUInt); inline;
begin
CVideoCtrlTagList(ViewPort, @TagList);