summaryrefslogtreecommitdiff
path: root/packages/unixutil
diff options
context:
space:
mode:
authorjoost <joost@3ad0048d-3df7-0310-abae-a5850022a9f2>2015-08-12 19:15:14 +0000
committerjoost <joost@3ad0048d-3df7-0310-abae-a5850022a9f2>2015-08-12 19:15:14 +0000
commit790f658e4b10a030b3d5126bb7045f3e0c3141ea (patch)
tree780c72509bfbfc9da4ec4dbe0551d433075b9e37 /packages/unixutil
parent354fb50e4b9313a8fa7b9442ccc9481ef8bdb1b6 (diff)
downloadfpc-790f658e4b10a030b3d5126bb7045f3e0c3141ea.tar.gz
* Filter the Makefile's unit searchpaths from the fpmake command line.
To void cluttering the .fpm file git-svn-id: http://svn.freepascal.org/svn/fpc/trunk@31317 3ad0048d-3df7-0310-abae-a5850022a9f2
Diffstat (limited to 'packages/unixutil')
-rw-r--r--packages/unixutil/Makefile.fpc4
1 files changed, 3 insertions, 1 deletions
diff --git a/packages/unixutil/Makefile.fpc b/packages/unixutil/Makefile.fpc
index de1d838ca2..337dff589d 100644
--- a/packages/unixutil/Makefile.fpc
+++ b/packages/unixutil/Makefile.fpc
@@ -26,9 +26,11 @@ endif
LOCALFPMAKE=./fpmake$(SRCEXEEXT)
[rules]
-# Do not pass the Makefile's unit and binary target locations. fpmake uses it's own.
+# Do not pass the Makefile's unit and binary target locations. Fpmake uses it's own.
override FPCOPT:=$(filter-out -FU%,$(FPCOPT))
override FPCOPT:=$(filter-out -FE%,$(FPCOPT))
+# Do not pass the package-unitdirectories. Fpmake adds those and this way they don't apear in the .fpm
+override FPCOPT:=$(filter-out $(addprefix -Fu,$(COMPILER_UNITDIR)),$(FPCOPT))# Compose general fpmake-parameters
# Compose general fpmake-parameters
ifdef FPMAKEOPT
FPMAKE_OPT+=$(FPMAKEOPT)