summaryrefslogtreecommitdiff
path: root/packages/unzip
diff options
context:
space:
mode:
authormicha <micha@3ad0048d-3df7-0310-abae-a5850022a9f2>2008-05-05 18:46:55 +0000
committermicha <micha@3ad0048d-3df7-0310-abae-a5850022a9f2>2008-05-05 18:46:55 +0000
commit7325927d2105f150bc7e2084b6d7e37e55c920ca (patch)
tree701e2a7a3138fdc3dd079958a6bde8d8342b8538 /packages/unzip
parent40bb5319c8e4dba3df47c8f48106d8bd29984398 (diff)
downloadfpc-7325927d2105f150bc7e2084b6d7e37e55c920ca.tar.gz
* regenerate Makefiles to get armeb-linux support globally (also arm-darwin, so it seems)
git-svn-id: http://svn.freepascal.org/svn/fpc/trunk@10888 3ad0048d-3df7-0310-abae-a5850022a9f2
Diffstat (limited to 'packages/unzip')
-rw-r--r--packages/unzip/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/packages/unzip/Makefile b/packages/unzip/Makefile
index 8668de60d3..e171925daf 100644
--- a/packages/unzip/Makefile
+++ b/packages/unzip/Makefile
@@ -1,8 +1,8 @@
#
-# Don't edit, this file is generated by FPCMake Version 2.0.0 [2008/03/24]
+# Don't edit, this file is generated by FPCMake Version 2.0.0 [2008/04/30]
#
default: all
-MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-netbsd i386-solaris i386-qnx i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian m68k-linux m68k-freebsd m68k-netbsd m68k-amiga m68k-atari m68k-openbsd m68k-palmos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-darwin x86_64-win64 x86_64-embedded arm-linux arm-palmos arm-wince arm-gba arm-nds arm-embedded arm-symbian powerpc64-linux powerpc64-darwin powerpc64-embedded avr-embedded armeb-linux armeb-embedded
+MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-netbsd i386-solaris i386-qnx i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian m68k-linux m68k-freebsd m68k-netbsd m68k-amiga m68k-atari m68k-openbsd m68k-palmos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-darwin x86_64-win64 x86_64-embedded arm-linux arm-palmos arm-darwin arm-wince arm-gba arm-nds arm-embedded arm-symbian powerpc64-linux powerpc64-darwin powerpc64-embedded avr-embedded armeb-linux armeb-embedded
BSDs = freebsd netbsd openbsd darwin
UNIXs = linux $(BSDs) solaris qnx
LIMIT83fs = go32v2 os2 emx watcom
@@ -388,6 +388,9 @@ endif
ifeq ($(FULL_TARGET),arm-palmos)
override TARGET_UNITS+=ziptypes unzip
endif
+ifeq ($(FULL_TARGET),arm-darwin)
+override TARGET_UNITS+=ziptypes unzip
+endif
ifeq ($(FULL_TARGET),arm-wince)
override TARGET_UNITS+=ziptypes unzip
endif
@@ -557,6 +560,9 @@ endif
ifeq ($(FULL_TARGET),arm-palmos)
override COMPILER_INCLUDEDIR+=src
endif
+ifeq ($(FULL_TARGET),arm-darwin)
+override COMPILER_INCLUDEDIR+=src
+endif
ifeq ($(FULL_TARGET),arm-wince)
override COMPILER_INCLUDEDIR+=src
endif
@@ -725,6 +731,9 @@ endif
ifeq ($(FULL_TARGET),arm-palmos)
override COMPILER_SOURCEDIR+=src tests
endif
+ifeq ($(FULL_TARGET),arm-darwin)
+override COMPILER_SOURCEDIR+=src tests
+endif
ifeq ($(FULL_TARGET),arm-wince)
override COMPILER_SOURCEDIR+=src tests
endif
@@ -1641,6 +1650,9 @@ endif
ifeq ($(FULL_TARGET),arm-palmos)
REQUIRE_PACKAGES_RTL=1
endif
+ifeq ($(FULL_TARGET),arm-darwin)
+REQUIRE_PACKAGES_RTL=1
+endif
ifeq ($(FULL_TARGET),arm-wince)
REQUIRE_PACKAGES_RTL=1
endif