summaryrefslogtreecommitdiff
path: root/packages/httpd20/examples/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/httpd20/examples/Makefile')
-rw-r--r--packages/httpd20/examples/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/packages/httpd20/examples/Makefile b/packages/httpd20/examples/Makefile
index 019fc72a8f..ef26b74fa5 100644
--- a/packages/httpd20/examples/Makefile
+++ b/packages/httpd20/examples/Makefile
@@ -196,6 +196,12 @@ $(error When compiling for mipsel-embedded, a sub-architecture (e.g. SUBARCH=pic
endif
override FPCOPT+=-Cp$(SUBARCH)
endif
+ifeq ($(FULL_TARGET),xtensa-embedded)
+ifeq ($(SUBARCH),)
+$(error When compiling for xtensa-embedded, a sub-architecture (e.g. SUBARCH=lx106 or SUBARCH=lx6) must be defined)
+endif
+override FPCOPT+=-Cp$(SUBARCH)
+endif
ifneq ($(findstring $(OS_SOURCE),$(LIMIT83fs)),)
TARGETSUFFIX=$(OS_TARGET)
SOURCESUFFIX=$(OS_SOURCE)
@@ -1117,15 +1123,12 @@ ifneq ($(CROSSGCC),)
GCCLIBDIR:=$(shell dirname `$(CROSSGCC) -print-libgcc-file-name`)
endif
endif
-ifndef OTHERLIBDIR
-OTHERLIBDIR:=$(shell grep -v "^\#" /etc/ld.so.conf | awk '{ ORS=" "; print $1 }')
-endif
endif
ifdef inUnix
ifeq ($(OS_SOURCE),netbsd)
-OTHERLIBDIR+=/usr/pkg/lib
+OTHERLIBDIR:=/usr/pkg/lib
endif
-export GCCLIBDIR OTHERLIB
+export GCCLIBDIR OTHERLIBDIR
endif
BATCHEXT=.bat
LOADEREXT=.as