summaryrefslogtreecommitdiff
path: root/packages/libndsfpc/examples/graphics/Printing/ansi_console/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/libndsfpc/examples/graphics/Printing/ansi_console/Makefile')
-rw-r--r--packages/libndsfpc/examples/graphics/Printing/ansi_console/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/packages/libndsfpc/examples/graphics/Printing/ansi_console/Makefile b/packages/libndsfpc/examples/graphics/Printing/ansi_console/Makefile
index 8050c965cd..06b0b7301b 100644
--- a/packages/libndsfpc/examples/graphics/Printing/ansi_console/Makefile
+++ b/packages/libndsfpc/examples/graphics/Printing/ansi_console/Makefile
@@ -2569,6 +2569,9 @@ STATICLIBEXT=.a
else
EXEEXT=.bin
endif
+ifeq ($(CPU_TARGET),z80)
+OEXT=.rel
+endif
SHORTSUFFIX=emb
endif
ifeq ($(OS_TARGET),win16)
@@ -2577,6 +2580,9 @@ STATICLIBEXT=.a
SHAREDLIBEXT=.dll
SHORTSUFFIX=w16
endif
+ifeq ($(OS_TARGET),zxspectrum)
+OEXT=.rel
+endif
ifneq ($(findstring $(OS_SOURCE),$(LIMIT83fs)),)
FPCMADE=fpcmade.$(SHORTSUFFIX)
ZIPSUFFIX=$(SHORTSUFFIX)