summaryrefslogtreecommitdiff
path: root/packages/libndsfpc/examples/input/keyboard/keyboard_stdin/Makefile.fpc
diff options
context:
space:
mode:
Diffstat (limited to 'packages/libndsfpc/examples/input/keyboard/keyboard_stdin/Makefile.fpc')
-rw-r--r--packages/libndsfpc/examples/input/keyboard/keyboard_stdin/Makefile.fpc46
1 files changed, 46 insertions, 0 deletions
diff --git a/packages/libndsfpc/examples/input/keyboard/keyboard_stdin/Makefile.fpc b/packages/libndsfpc/examples/input/keyboard/keyboard_stdin/Makefile.fpc
new file mode 100644
index 0000000000..78d24fd7d7
--- /dev/null
+++ b/packages/libndsfpc/examples/input/keyboard/keyboard_stdin/Makefile.fpc
@@ -0,0 +1,46 @@
+#
+# Makefile.fpc for Free Pascal libndsfpc 2.x.y Examples
+#
+
+[target]
+loaders=
+programs=keyboardStdin
+
+[require]
+packages=libndsfpc
+tools=bin2s mmutil grit
+nortl=y
+
+[install]
+fpcpackage=y
+
+[default]
+cpu=arm
+target=nds
+fpcdir=../../../../../..
+
+[clean]
+files=*.elf *.o *.s *.nds *.nef *.h *.bin \
+ $(BUILD)/*
+units=*
+
+[prerules]
+BUILD = build
+AUDIO_FILES = $(foreach dir,$(notdir $(wildcard audio/*.*)),$(CURDIR)/audio/$(dir))
+GFX_FILES = $(foreach dir,gfx,$(notdir $(wildcard $(dir)/*.png)))
+
+[rules]
+.NOTPARALLEL:
+all: direc fpc_all
+direc:
+ifneq ($(BUILD), $(CURDIR))
+ $(MKDIR) $(BUILD)
+endif
+soundbank.bin.o : $(AUDIO_FILES)
+ @$(MMUTIL) $^ -d -o$(BUILD)/soundbank.bin -h$(BUILD)/soundbank.h
+ $(BIN2S) $(BUILD)/soundbank.bin > $(BUILD)/soundbank.bin.s
+ $(AS) -o $(BUILD)/soundbank.bin.o $(BUILD)/soundbank.bin.s
+
+$(GFX_FILES).o:
+ $(GRIT) gfx/$(GFX_FILES) -fts -ff gfx/$(basename $(GFX_FILES)).grit -o$(BUILD)/$(GFX_FILES)
+ $(AS) -o $(BUILD)/$(basename $(GFX_FILES)).o $(BUILD)/$(basename $(GFX_FILES)).s