summaryrefslogtreecommitdiff
path: root/packages/libndsfpc
diff options
context:
space:
mode:
Diffstat (limited to 'packages/libndsfpc')
-rw-r--r--packages/libndsfpc/Makefile.fpc4
1 files changed, 3 insertions, 1 deletions
diff --git a/packages/libndsfpc/Makefile.fpc b/packages/libndsfpc/Makefile.fpc
index 9383ca8b34..cb8a3bbcde 100644
--- a/packages/libndsfpc/Makefile.fpc
+++ b/packages/libndsfpc/Makefile.fpc
@@ -26,9 +26,11 @@ endif
LOCALFPMAKE=./fpmake$(SRCEXEEXT)
[rules]
-# Do not pass the Makefile's unit and binary target locations. fpmake uses it's own.
+# Do not pass the Makefile's unit and binary target locations. Fpmake uses it's own.
override FPCOPT:=$(filter-out -FU%,$(FPCOPT))
override FPCOPT:=$(filter-out -FE%,$(FPCOPT))
+# Do not pass the package-unitdirectories. Fpmake adds those and this way they don't apear in the .fpm
+override FPCOPT:=$(filter-out $(addprefix -Fu,$(COMPILER_UNITDIR)),$(FPCOPT))# Compose general fpmake-parameters
# Compose general fpmake-parameters
ifdef FPMAKEOPT
FPMAKE_OPT+=$(FPMAKEOPT)