summaryrefslogtreecommitdiff
path: root/packages/libogcfpc/examples/devices/usbkeyboard/basic_stdin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/libogcfpc/examples/devices/usbkeyboard/basic_stdin/Makefile')
-rw-r--r--packages/libogcfpc/examples/devices/usbkeyboard/basic_stdin/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/packages/libogcfpc/examples/devices/usbkeyboard/basic_stdin/Makefile b/packages/libogcfpc/examples/devices/usbkeyboard/basic_stdin/Makefile
index 88594a83e1..633010eccd 100644
--- a/packages/libogcfpc/examples/devices/usbkeyboard/basic_stdin/Makefile
+++ b/packages/libogcfpc/examples/devices/usbkeyboard/basic_stdin/Makefile
@@ -198,6 +198,12 @@ $(error When compiling for mipsel-embedded, a sub-architecture (e.g. SUBARCH=pic
endif
override FPCOPT+=-Cp$(SUBARCH)
endif
+ifeq ($(FULL_TARGET),xtensa-embedded)
+ifeq ($(SUBARCH),)
+$(error When compiling for xtensa-embedded, a sub-architecture (e.g. SUBARCH=lx106 or SUBARCH=lx6) must be defined)
+endif
+override FPCOPT+=-Cp$(SUBARCH)
+endif
ifneq ($(findstring $(OS_SOURCE),$(LIMIT83fs)),)
TARGETSUFFIX=$(OS_TARGET)
SOURCESUFFIX=$(OS_SOURCE)