summaryrefslogtreecommitdiff
path: root/packages/libogcfpc/examples/graphics/gx/gxSprites/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/libogcfpc/examples/graphics/gx/gxSprites/Makefile')
-rw-r--r--packages/libogcfpc/examples/graphics/gx/gxSprites/Makefile51
1 files changed, 48 insertions, 3 deletions
diff --git a/packages/libogcfpc/examples/graphics/gx/gxSprites/Makefile b/packages/libogcfpc/examples/graphics/gx/gxSprites/Makefile
index 71794f329f..13738efbd3 100644
--- a/packages/libogcfpc/examples/graphics/gx/gxSprites/Makefile
+++ b/packages/libogcfpc/examples/graphics/gx/gxSprites/Makefile
@@ -1,10 +1,10 @@
#
-# Don't edit, this file is generated by FPCMake Version 2.0.0 [2012/04/05]
+# Don't edit, this file is generated by FPCMake Version 2.0.0 [2012/04/11]
#
default: all
-MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-haiku i386-netbsd i386-solaris i386-qnx i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian i386-nativent i386-iphonesim m68k-linux m68k-freebsd m68k-netbsd m68k-amiga m68k-atari m68k-openbsd m68k-palmos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded powerpc-wii sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-solaris x86_64-openbsd x86_64-darwin x86_64-win64 x86_64-embedded arm-linux arm-palmos arm-darwin arm-wince arm-gba arm-nds arm-embedded arm-symbian powerpc64-linux powerpc64-darwin powerpc64-embedded avr-embedded armeb-linux armeb-embedded mips-linux mipsel-linux
+MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-haiku i386-netbsd i386-solaris i386-qnx i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian i386-nativent i386-iphonesim m68k-linux m68k-freebsd m68k-netbsd m68k-amiga m68k-atari m68k-openbsd m68k-palmos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded powerpc-wii powerpc-aix sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-solaris x86_64-openbsd x86_64-darwin x86_64-win64 x86_64-embedded arm-linux arm-palmos arm-darwin arm-wince arm-gba arm-nds arm-embedded arm-symbian powerpc64-linux powerpc64-darwin powerpc64-embedded powerpc64-aix avr-embedded armeb-linux armeb-embedded mips-linux mipsel-linux
BSDs = freebsd netbsd openbsd darwin
-UNIXs = linux $(BSDs) solaris qnx haiku
+UNIXs = linux $(BSDs) solaris qnx haiku aix
LIMIT83fs = go32v2 os2 emx watcom
OSNeedsComspecToRunBatch = go32v2 watcom
FORCE:
@@ -414,6 +414,9 @@ endif
ifeq ($(FULL_TARGET),powerpc-wii)
override TARGET_PROGRAMS+=gxsprites
endif
+ifeq ($(FULL_TARGET),powerpc-aix)
+override TARGET_PROGRAMS+=gxsprites
+endif
ifeq ($(FULL_TARGET),sparc-linux)
override TARGET_PROGRAMS+=gxsprites
endif
@@ -480,6 +483,9 @@ endif
ifeq ($(FULL_TARGET),powerpc64-embedded)
override TARGET_PROGRAMS+=gxsprites
endif
+ifeq ($(FULL_TARGET),powerpc64-aix)
+override TARGET_PROGRAMS+=gxsprites
+endif
ifeq ($(FULL_TARGET),avr-embedded)
override TARGET_PROGRAMS+=gxsprites
endif
@@ -609,6 +615,9 @@ endif
ifeq ($(FULL_TARGET),powerpc-wii)
override CLEAN_UNITS+=*
endif
+ifeq ($(FULL_TARGET),powerpc-aix)
+override CLEAN_UNITS+=*
+endif
ifeq ($(FULL_TARGET),sparc-linux)
override CLEAN_UNITS+=*
endif
@@ -675,6 +684,9 @@ endif
ifeq ($(FULL_TARGET),powerpc64-embedded)
override CLEAN_UNITS+=*
endif
+ifeq ($(FULL_TARGET),powerpc64-aix)
+override CLEAN_UNITS+=*
+endif
ifeq ($(FULL_TARGET),avr-embedded)
override CLEAN_UNITS+=*
endif
@@ -804,6 +816,9 @@ endif
ifeq ($(FULL_TARGET),powerpc-wii)
override CLEAN_FILES+=*.elf *.o *.s *.h *.bin *.map $(BUILD)/* $(INC)/*
endif
+ifeq ($(FULL_TARGET),powerpc-aix)
+override CLEAN_FILES+=*.elf *.o *.s *.h *.bin *.map $(BUILD)/* $(INC)/*
+endif
ifeq ($(FULL_TARGET),sparc-linux)
override CLEAN_FILES+=*.elf *.o *.s *.h *.bin *.map $(BUILD)/* $(INC)/*
endif
@@ -870,6 +885,9 @@ endif
ifeq ($(FULL_TARGET),powerpc64-embedded)
override CLEAN_FILES+=*.elf *.o *.s *.h *.bin *.map $(BUILD)/* $(INC)/*
endif
+ifeq ($(FULL_TARGET),powerpc64-aix)
+override CLEAN_FILES+=*.elf *.o *.s *.h *.bin *.map $(BUILD)/* $(INC)/*
+endif
ifeq ($(FULL_TARGET),avr-embedded)
override CLEAN_FILES+=*.elf *.o *.s *.h *.bin *.map $(BUILD)/* $(INC)/*
endif
@@ -1000,6 +1018,9 @@ endif
ifeq ($(FULL_TARGET),powerpc-wii)
override COMPILER_OPTIONS+=-g -Xm
endif
+ifeq ($(FULL_TARGET),powerpc-aix)
+override COMPILER_OPTIONS+=-g -Xm
+endif
ifeq ($(FULL_TARGET),sparc-linux)
override COMPILER_OPTIONS+=-g -Xm
endif
@@ -1066,6 +1087,9 @@ endif
ifeq ($(FULL_TARGET),powerpc64-embedded)
override COMPILER_OPTIONS+=-g -Xm
endif
+ifeq ($(FULL_TARGET),powerpc64-aix)
+override COMPILER_OPTIONS+=-g -Xm
+endif
ifeq ($(FULL_TARGET),avr-embedded)
override COMPILER_OPTIONS+=-g -Xm
endif
@@ -1433,6 +1457,11 @@ EXEEXT=.dol
SHAREDLIBEXT=.so
SHORTSUFFIX=wii
endif
+ifeq ($(OS_TARGET),aix)
+BATCHEXT=.sh
+EXEEXT=
+SHORTSUFFIX=aix
+endif
ifneq ($(findstring $(OS_SOURCE),$(LIMIT83fs)),)
FPCMADE=fpcmade.$(SHORTSUFFIX)
ZIPSUFFIX=$(SHORTSUFFIX)
@@ -1979,6 +2008,14 @@ REQUIRE_PACKAGES_HASH=1
REQUIRE_PACKAGES_FPMKUNIT=1
REQUIRE_PACKAGES_LIBOGCFPC=1
endif
+ifeq ($(FULL_TARGET),powerpc-aix)
+REQUIRE_PACKAGES_RTL=1
+REQUIRE_PACKAGES_PASZLIB=1
+REQUIRE_PACKAGES_FCL-PROCESS=1
+REQUIRE_PACKAGES_HASH=1
+REQUIRE_PACKAGES_FPMKUNIT=1
+REQUIRE_PACKAGES_LIBOGCFPC=1
+endif
ifeq ($(FULL_TARGET),sparc-linux)
REQUIRE_PACKAGES_RTL=1
REQUIRE_PACKAGES_PASZLIB=1
@@ -2155,6 +2192,14 @@ REQUIRE_PACKAGES_HASH=1
REQUIRE_PACKAGES_FPMKUNIT=1
REQUIRE_PACKAGES_LIBOGCFPC=1
endif
+ifeq ($(FULL_TARGET),powerpc64-aix)
+REQUIRE_PACKAGES_RTL=1
+REQUIRE_PACKAGES_PASZLIB=1
+REQUIRE_PACKAGES_FCL-PROCESS=1
+REQUIRE_PACKAGES_HASH=1
+REQUIRE_PACKAGES_FPMKUNIT=1
+REQUIRE_PACKAGES_LIBOGCFPC=1
+endif
ifeq ($(FULL_TARGET),avr-embedded)
REQUIRE_PACKAGES_RTL=1
REQUIRE_PACKAGES_PASZLIB=1