summaryrefslogtreecommitdiff
path: root/packages/odata/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/odata/Makefile')
-rw-r--r--packages/odata/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/packages/odata/Makefile b/packages/odata/Makefile
index d77d01bcce..70e0e19441 100644
--- a/packages/odata/Makefile
+++ b/packages/odata/Makefile
@@ -607,10 +607,18 @@ else
ifneq ($(findstring $(FPCFPMAKE_CPU_OPT),mips mipsel),)
FPCMAKE_CROSSGCCOPT=-mabi=32
else
+ifneq ($(findstring $(FPCFPMAKE_CPU_OPT),riscv64),)
+FPCMAKE_CROSSGCCOPT=-mabi=lp64
+else
+ifneq ($(findstring $(FPCFPMAKE_CPU_OPT),riscv32),)
+FPCMAKE_CROSSGCCOPT=-mabi=ilp32
+else
FPCMAKE_CROSSGCCOPT=-m32
endif
endif
endif
+endif
+endif
FPCMAKEGCCLIBDIR:=$(shell dirname `gcc $(FPCMAKE_CROSSGCCOPT) -print-libgcc-file-name`)
endif
endif