summaryrefslogtreecommitdiff
path: root/packages/oracle/Makefile.fpc.fpcmake
diff options
context:
space:
mode:
Diffstat (limited to 'packages/oracle/Makefile.fpc.fpcmake')
-rw-r--r--packages/oracle/Makefile.fpc.fpcmake36
1 files changed, 36 insertions, 0 deletions
diff --git a/packages/oracle/Makefile.fpc.fpcmake b/packages/oracle/Makefile.fpc.fpcmake
new file mode 100644
index 0000000000..a99a301995
--- /dev/null
+++ b/packages/oracle/Makefile.fpc.fpcmake
@@ -0,0 +1,36 @@
+#
+# Makefile.fpc for oracle units
+#
+
+[package]
+name=oracle
+version=2.7.1
+
+[target]
+units=oci ocidyn oratypes oraoci
+exampledirs=examples
+
+[require]
+libc=y
+
+[install]
+fpcpackage=y
+
+[default]
+fpcdir=../..
+
+[compiler]
+includedir=src
+sourcedir=src tests
+
+# in libdir variable must be path to libraries
+# libclntsh.*,libnlsrtl3.*
+#[compiler]
+#libdir=/usr/local/oracle8cli/lib
+
+[shared]
+build=n
+
+[rules]
+.NOTPARALLEL:
+