summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Turner <david@freetype.org>2020-07-02 10:31:28 +0200
committerWerner Lemberg <wl@gnu.org>2020-07-05 09:59:29 +0200
commit0322efb5e5fcd2c64f9fb433b890ff476abb696f (patch)
treeca18797682534ff359e269d3b9417b16cd279db2 /CMakeLists.txt
parentbd7251ac97eea134873118f4d9f005c333e31953 (diff)
downloadfreetype2-0322efb5e5fcd2c64f9fb433b890ff476abb696f.tar.gz
[build] Move mac support code to `mac-support.h'.
* builds/unix/ftconfig.h.in, builds/vms/ftconfig.h, include/freetype/config/ftconfig.h: Split off mac-specific stuff to... * include/freetype/config/mac-support.h: ...this new file. * CMakeLists.txt, builds/unix/configure.raw: Remove `/undef -> #undef' string replacement; the affected code is no longer part of the `ftconfig.h' template.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 642b023e1..c9befb421 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -253,8 +253,6 @@ if (UNIX)
"#undef +(HAVE_FCNTL_H)" "#define \\1 1"
FTCONFIG_H "${FTCONFIG_H}")
endif ()
- string(REPLACE "/undef " "#undef "
- FTCONFIG_H "${FTCONFIG_H}")
else ()
file(READ "${PROJECT_SOURCE_DIR}/include/freetype/config/ftconfig.h"
FTCONFIG_H)