summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorWerner Lemberg <wl@gnu.org>2021-11-21 11:01:37 +0100
committerWerner Lemberg <wl@gnu.org>2021-11-21 11:01:59 +0100
commit407f31ff87a1e35a1cf3daee4fa5f22165de5f6f (patch)
treea620b57df74582fb30ae09f6f4826404638e5f06 /meson.build
parent896630bed63d42feb246a5781fe7d90e484362a1 (diff)
downloadfreetype2-407f31ff87a1e35a1cf3daee4fa5f22165de5f6f.tar.gz
meson.build: Initialize `common_ldflags`.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 74fde432f..9998848d5 100644
--- a/meson.build
+++ b/meson.build
@@ -234,16 +234,18 @@ else
ft2_sources += 'src/base/ftdebug.c'
endif
+
ft2_deps = []
+common_ldflags = []
-# Correct compatibility version for OS x
+# Correct compatibility version for OS x.
#
# OSX sets the compatibility_version (aka libtools version) differently from
# the library name.
#
if host_machine.system() == 'darwin'
- # Maintain compatibility with autotools on macOS
+ # maintain compatibility with autotools on macOS
common_ldflags = [
'-compatibility_version', ft2_pkgconfig_version.split('.')[0],
'-current_version', ft2_pkgconfig_version