summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2021-02-13 16:32:26 -0500
committerWerner Lemberg <wl@gnu.org>2021-03-07 17:48:15 +0100
commitd69d9c2397afc86e95fef48226364723e14d506c (patch)
tree46f2db05b00ff2fc33386d00b5a33d21483858ff /meson.build
parent7227aabb3e45e46cf320f56503656c39f8b63b30 (diff)
downloadfreetype2-d69d9c2397afc86e95fef48226364723e14d506c.tar.gz
[meson] Make it work with Windows.
* meson.build: Do not process `ftconfig.h` when not using `ftconfig.h.in`. Fixes #1029.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build22
1 files changed, 10 insertions, 12 deletions
diff --git a/meson.build b/meson.build
index dc322553b..93b489487 100644
--- a/meson.build
+++ b/meson.build
@@ -288,6 +288,7 @@ if host_machine.system() == 'windows'
ft2_defines += ['-DDLL_EXPORT=1']
endif
+
# Generate `ftconfig.h`
ftconfig_command = process_header_command
@@ -300,20 +301,17 @@ endif
if host_machine.system() in ['linux', 'darwin', 'cygwin']
ftconfig_h_in = files('builds/unix/ftconfig.h.in')
-else
- ftconfig_h_in = files('include/freetype/config/ftconfig.h')
+ ftconfig_h = custom_target('ftconfig.h',
+ input: ftconfig_h_in,
+ output: 'ftconfig.h',
+ command: ftconfig_command,
+ install: true,
+ install_dir: 'include/freetype2/freetype/config',
+ )
+ ft2_sources += ftconfig_h
+ ft2_defines += ['-DFT_CONFIG_CONFIG_H=<ftconfig.h>']
endif
-ftconfig_h = custom_target('ftconfig.h',
- input: ftconfig_h_in,
- output: 'ftconfig.h',
- command: ftconfig_command,
- install: true,
- install_dir: 'include/freetype2/freetype/config',
-)
-ft2_sources += ftconfig_h
-ft2_defines += ['-DFT_CONFIG_CONFIG_H=<ftconfig.h>']
-
ft2_lib = library('freetype',
sources: ft2_sources + [ftmodule_h],