summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorDavid Turner <david@freetype.org>2021-06-15 23:12:57 +0200
committerDavid Turner <david@freetype.org>2021-06-16 10:28:47 +0200
commit6f273f68788265b2bf0a127be68062f5eaccbb1b (patch)
tree15ef2ed0fa826f5961e6d5da508509deea23ce8d /tests/meson.build
parentc6fcd61228ea349e76aa4f09442c431308da3262 (diff)
downloadfreetype2-6f273f68788265b2bf0a127be68062f5eaccbb1b.tar.gz
[meson] Add first regression test to FreeType
* tests/README.md: documentation explaining how to build and run the tests with the Meson build. * tests/scripts/download-test-fonts.sh: Simple script to download test font files to the 'tests/data/' folder. * meson.build, meson_options.txt, tests/meson.build: Add 'tests' option to enable building and running the test programs, disabled by default. * tests/issue-1063/main.c: Simple regression test to exhibit issue 1063. * .gitignore: Ignore the content of the tests/data/ folder for now.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 000000000..8c5d0345f
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,7 @@
+test_issue_1063 = executable('issue-1063',
+ files([ 'issue-1063/main.c' ]),
+ dependencies: freetype_dep,
+)
+
+test('issue-1063', test_issue_1063, suite: 'regression')
+