summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorAlex Richardson <Alexander.Richardson@cl.cam.ac.uk>2021-07-15 18:26:20 +0100
committerWerner Lemberg <wl@gnu.org>2021-07-16 14:42:51 +0200
commit7bc0f48c274e2d1c7525ce5025351149b0803a91 (patch)
tree3cb9748504224d5bd4eba6f01fe770c113d453f4 /tests/meson.build
parent685acc04dbad5ece9b7261d21f4a2546d787436c (diff)
downloadfreetype2-7bc0f48c274e2d1c7525ce5025351149b0803a91.tar.gz
[tests] Allow arbitrary build directories.
* tests/issue-1063/main.c (main): I am building with a build directory that is not directly inside the source tree, so the path `../tests/data/As.I.Lay.Dying.ttf` does not resolve to the test input file. This change passes the test data directory as an environment variable to allow arbitrary build directories. * tests/meson.build: Updated.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 8c5d0345f..527998ffa 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -3,5 +3,12 @@ test_issue_1063 = executable('issue-1063',
dependencies: freetype_dep,
)
-test('issue-1063', test_issue_1063, suite: 'regression')
+test_env = ['FREETYPE_TESTS_DATA_DIR='
+ + join_paths(meson.current_source_dir(), 'data')]
+test('issue-1063',
+ test_issue_1063,
+ env: test_env,
+ suite: 'regression')
+
+# EOF