summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorbehdad <behdad>2004-06-14 18:43:48 +0000
committerbehdad <behdad>2004-06-14 18:43:48 +0000
commit08dd824be4a114ed07d67c5dabc12c33fd6ba3ae (patch)
tree5fb7723a0f98048526ddaf67aafc7ef871185530 /configure.ac
parent5e32eff3de2d41d4a1674e28991eb82c1d00dd79 (diff)
downloadfribidi-08dd824be4a114ed07d67c5dabc12c33fd6ba3ae.tar.gz
fribidi-bidi-type.[ch] merged into fribidi-bidi-types.[ch].
fribidi-joining-type.[ch] merged into fribidi-joining-types.[ch].
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 17 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 4c1fd33..ed50e63 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,10 +3,10 @@
## Use autoupdate to update this file for newer versions of autoconf.
## Use autoscan to check if you need to add something to this file.
##############################################################################
-## $Id: configure.ac,v 1.14 2004-06-09 20:01:00 behdad Exp $
+## $Id: configure.ac,v 1.15 2004-06-14 18:43:48 behdad Exp $
## $Auther: behdad $
-## $Date: 2004-06-09 20:01:00 $
-## $Revision: 1.14 $
+## $Date: 2004-06-14 18:43:48 $
+## $Revision: 1.15 $
## $Source: /home/behdad/src/fdo/fribidi/togit/git/../fribidi/fribidi2/configure.ac,v $
##############################################################################
@@ -44,7 +44,7 @@ m4_define(fribidi_version,
fribidi_major_version.fribidi_minor_version.fribidi_micro_version))dnl
AC_INIT([GNU FriBidi],fribidi_version(),[http://freedesktop.org/cgi-bin/bugzilla/enter_bug.cgi?product=FriBidi])
-AC_REVISION([$Id: configure.ac,v 1.14 2004-06-09 20:01:00 behdad Exp $])
+AC_REVISION([$Id: configure.ac,v 1.15 2004-06-14 18:43:48 behdad Exp $])
AC_CONFIG_SRCDIR(lib/fribidi.h)
AC_CONFIG_HEADERS(config.h)
AM_INIT_AUTOMAKE([gnits])
@@ -152,7 +152,7 @@ fi
# --disable-charsets
AC_ARG_ENABLE(charsets,
AC_HELP_STRING([--disable-charsets],
- [exclude charset conversion routines from the library]))
+ [exclude charset conversion routines from library]))
if test x$enable_charsets = xno; then
FRIBIDI_CHARSETS=0
else
@@ -161,6 +161,18 @@ fi
AC_SUBST(FRIBIDI_CHARSETS)
AM_CONDITIONAL(FRIBIDI_CHARSETS, test x$FRIBIDI_CHARSETS = x1)
+# --disable-arabic
+AC_ARG_ENABLE(arabic,
+ AC_HELP_STRING([--disable-arabic],
+ [exclude Arabic joining/shaping code from library]))
+if test x$enable_arabic = xno; then
+ FRIBIDI_NO_ARABIC=1
+else
+ FRIBIDI_NO_ARABIC=0
+fi
+AC_SUBST(FRIBIDI_NO_ARABIC)
+AM_CONDITIONAL(FRIBIDI_NO_ARABIC, test x$FRIBIDI_NO_ARABIC = x1)
+
# --with[out]-glib
AC_ARG_WITH(glib,
AC_HELP_STRING([--with-glib=@<:@no/auto/yes@:>@],