summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorKhaled Hosny <khaledhosny@eglug.org>2018-02-04 14:32:00 +0200
committerKhaled Hosny <khaledhosny@eglug.org>2018-02-04 14:42:22 +0200
commitef060ddc48b83885c6f094bc2120444550decdbc (patch)
tree9226a4437473e35bf095275e6c70c341fe24a6a8 /doc/Makefile.am
parentd18badec88bca8f6f4149156ebe7f1c6467a7bd8 (diff)
downloadfribidi-ef060ddc48b83885c6f094bc2120444550decdbc.tar.gz
Fix parallel build
Parallel build was failing while building the man pages. doc/Makefile.am tries cleverly to handle the fact that c2man produces all the man pages at once, following the approach described in: https://www.gnu.org/software/automake/manual/html_node/Multiple-Outputs.html However this is failing because c2man is not generating all the requested man pages, so the rule ends being run multiple times instead of once and parallel builds are broken. One of the requested pages is for a function that doesn’t exist, fribidi_log2vis_get_embedding_levels_ex, so I removed it from fribidi.def. Two functions were not documented, so I added minimal documentation for them. But the last two are for variables not functions and c2man does not like that it seems so I added a hack to drop these two as well without modifying fribidi.def. Fixes https://github.com/fribidi/fribidi/issues/45
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index fd1d160..d9d5c02 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -27,7 +27,8 @@ include $(top_srcdir)/lib/Headers.mk
headers += $(libfribidi_la_headers)
includepath += -I$(top_builddir)/lib -I$(top_srcdir)/lib
includevpath += :$(top_builddir)/lib:$(top_srcdir)/lib
-inst_symbols += $(libfribidi_la_symbols)
+# The las two lines are not functions, we don't want them here.
+inst_symbols += $(shell head -n -2 $(top_srcdir)/lib/fribidi.def)
dist_man_MANS += $(inst_symbols:=.3)
dist_noinst_MANS += $(noinst_symbols:=.3)