summaryrefslogtreecommitdiff
path: root/lib/meson.build
diff options
context:
space:
mode:
authorBill Zissimopoulos <billziss@navimatics.com>2019-12-31 01:58:57 -0800
committerNikolaus Rath <Nikolaus@rath.org>2019-12-31 09:58:57 +0000
commitabdd45f83cea86410536d9a45aa317cc0511d9d2 (patch)
treeb8a43cbf6954caca556b9219f8bafa107b4ac66b /lib/meson.build
parentb5060b0642f6f97a934c4fc6a8d4dcd84d454fe7 (diff)
downloadfuse-abdd45f83cea86410536d9a45aa317cc0511d9d2.tar.gz
Make ioctl prototype conditional on FUSE_USE_VERSION. (#482)
Define FUSE_USE_VERSION < 35 to get old ioctl prototype with int commands; define FUSE_USE_VERSION >= 35 to get new ioctl prototype with unsigned int commands. Fixes #463.
Diffstat (limited to 'lib/meson.build')
-rw-r--r--lib/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/meson.build b/lib/meson.build
index 28f0aee..98461d8 100644
--- a/lib/meson.build
+++ b/lib/meson.build
@@ -37,7 +37,7 @@ libfuse = library('fuse3', libfuse_sources, version: meson.project_version(),
soversion: '3', include_directories: include_dirs,
dependencies: deps, install: true,
link_depends: 'fuse_versionscript',
- c_args: [ '-DFUSE_USE_VERSION=34',
+ c_args: [ '-DFUSE_USE_VERSION=35',
'-DFUSERMOUNT_DIR="@0@"'.format(fusermount_path) ],
link_args: ['-Wl,--version-script,' + meson.current_source_dir()
+ '/fuse_versionscript' ])