summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNikolaus Rath <Nikolaus@rath.org>2019-05-05 13:11:03 -0400
committerNikolaus Rath <Nikolaus@rath.org>2019-05-09 14:16:37 -0500
commit055f272517306e6877a126e414aa60191b483eba (patch)
treea37dc1d38ad5fd2d76cb67dc32ba12ed445636a6 /meson.build
parent625ed81b823b927ce7fdb1d34def624ceb2f3553 (diff)
downloadfuse-055f272517306e6877a126e414aa60191b483eba.tar.gz
Added new example filesystem
passthrough_hp puts emphasis and performance and correctness, rather than simplicity.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 5797fec..c51d869 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,4 @@
-project('libfuse3', 'c', version: '3.5.0',
+project('libfuse3', ['cpp', 'c'], version: '3.5.0',
meson_version: '>= 0.42',
default_options: [ 'buildtype=debugoptimized' ])
@@ -66,6 +66,10 @@ configure_file(output: 'config.h',
add_project_arguments('-D_REENTRANT', '-DHAVE_CONFIG_H', '-Wall', '-Wextra', '-Wno-sign-compare',
'-Wstrict-prototypes', '-Wmissing-declarations', '-Wwrite-strings',
'-fno-strict-aliasing', language: 'c')
+add_project_arguments('-D_REENTRANT', '-DHAVE_CONFIG_H', '-D_GNU_SOURCE',
+ '-Wall', '-Wextra', '-Wno-sign-compare', '-std=c++11',
+ '-Wmissing-declarations', '-Wwrite-strings',
+ '-fno-strict-aliasing', language: 'cpp')
# Some (stupid) GCC versions warn about unused return values even when they are
# casted to void. This makes -Wunused-result pretty useless, since there is no