summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorasafkahlon <35964924+asafkahlon@users.noreply.github.com>2021-06-09 11:07:25 +0300
committerGitHub <noreply@github.com>2021-06-09 09:07:25 +0100
commitc7a8b42f3120af0822c6bb0e6c1756980ac48c8f (patch)
treebf1a6d3d9094379f683b9a5f47dcfd881c52990c /meson.build
parent57b46adc35bd31e0a786a7c753590a5ce41ce6f7 (diff)
downloadfuse-c7a8b42f3120af0822c6bb0e6c1756980ac48c8f.tar.gz
Add an option to disable building tests (#533)
Signed-off-by: Asaf Kahlon <asafka7@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6feb0a5..79a18c6 100644
--- a/meson.build
+++ b/meson.build
@@ -125,7 +125,7 @@ thread_dep = dependency('threads')
#
# Read build files from sub-directories
#
-subdirs = [ 'lib', 'include', 'test' ]
+subdirs = [ 'lib', 'include']
if get_option('utils') and not platform.endswith('bsd') and platform != 'dragonfly'
subdirs += [ 'util', 'doc' ]
endif
@@ -134,6 +134,10 @@ if get_option('examples')
subdirs += 'example'
endif
+if get_option('tests')
+ subdirs += 'test'
+endif
+
foreach n : subdirs
subdir(n)
endforeach