summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArnold D. Robbins <arnold@skeeve.com>2016-08-23 06:05:01 +0300
committerArnold D. Robbins <arnold@skeeve.com>2016-08-23 06:05:01 +0300
commit273c35356b59a2d3b989bd568f577aaf800dc4a5 (patch)
tree3bc9b2f5a3c5466f2d436c1029e92cf2f221fb4c /Makefile.am
parent4a920a6b4214dfc118eeeffd28b3dff33127a9b5 (diff)
parent546f826812728eb8a7b9e51408929c7314b92d31 (diff)
downloadgawk-273c35356b59a2d3b989bd568f577aaf800dc4a5.tar.gz
Merge branch 'gawk-4.1-stable'
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 0bc2143e..dce65018 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -185,16 +185,16 @@ check-local: gawk$(EXEEXT)
# A little extra clean up when making distributions.
# And additional set up for the pc directory.
dist-hook:
- cd $(distdir)/extension ; rm -f *.o *.so
- cd $(srcdir)/pc ; \
+ cd "$(distdir)"/extension ; rm -f *.o *.so
+ cd "$(srcdir)"/pc ; \
chmod u+w config.h ; \
sed -n -f configpk.sed < ../configure.ac > /tmp/tmp.sed ; \
sed -f config.sed < ../configh.in > /tmp/config.tmp ; \
sed -f /tmp/tmp.sed < /tmp/config.tmp > config.h ; \
$(RM) /tmp/tmp.sed /tmp/config.tmp
pwd
- chmod u+w $(distdir)/pc/config.h
- cp $(srcdir)/pc/config.h $(distdir)/pc/config.h
+ chmod u+w "$(distdir)"/pc/config.h
+ cp "$(srcdir)"/pc/config.h "$(distdir)"/pc/config.h
# Special rules for individual files
# Use of awk instead of $(AWK) is deliberate, in case gawk doesn't build
@@ -202,14 +202,14 @@ dist-hook:
awkgram.c: awkgram.y
$(YACC) $(AM_YFLAGS) $(YFLAGS) $<
- sed 's/parse error/syntax error/g' < y.tab.c | awk -f $(srcdir)/bisonfix.awk awkgram > $*.c && rm y.tab.c
+ sed 's/parse error/syntax error/g' < y.tab.c | awk -f "$(srcdir)"/bisonfix.awk awkgram > $*.c && rm y.tab.c
if test -f y.tab.h; then \
if cmp -s y.tab.h $*.h; then rm -f y.tab.h; else mv y.tab.h $*.h; fi; \
else :; fi
command.c: command.y
$(YACC) -p zz $<
- sed 's/parse error/syntax error/g' < y.tab.c | awk -f $(srcdir)/bisonfix.awk command > $*.c && rm y.tab.c
+ sed 's/parse error/syntax error/g' < y.tab.c | awk -f "$(srcdir)"/bisonfix.awk command > $*.c && rm y.tab.c
# This is for my development & testing.
efence: gawk
@@ -227,3 +227,6 @@ valgrind-noleak:
cd test; rm -f log.[0-9]*; \
make check VALGRIND="valgrind --leak-check=no --log-file=log.%p"; \
make valgrind-scan
+
+spell:
+ cd "$(srcdir)"/doc ; $(MAKE) spell