summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArnold D. Robbins <arnold@skeeve.com>2015-10-16 08:19:47 +0300
committerArnold D. Robbins <arnold@skeeve.com>2015-10-16 08:19:47 +0300
commitf637abf1afe96ea36717ee4365b9405b0c7c1b17 (patch)
tree22dd5a74571623645522e8e826bd1ab135640e03 /Makefile.am
parent611dc46d8b216c22f05604e8df6bee7aa59e5977 (diff)
downloadgawk-f637abf1afe96ea36717ee4365b9405b0c7c1b17.tar.gz
Fix build ordering issues.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 342df292..460f9114 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -59,21 +59,24 @@ EXTRA_DIST = \
ylwrap
# The order to do things in.
+#
# Build explicitly in "." in order to build gawk first, so
# that `make check' without a prior `make' works.
+#
+# Build in extension before test so that
+# ./configure && make check
+# works properly too.
+#
# Build in awklib after in doc, since we want to extract
# sample files if doc/gawk.texi changed.
-SUBDIRS = \
- . \
- doc \
- awklib \
- po \
- test
+SUBDIRS = .
if ENABLE_EXTENSIONS
SUBDIRS += extension
endif
+SUBDIRS += doc awklib po test
+
# what to make and install
bin_PROGRAMS = gawk
include_HEADERS = gawkapi.h