summaryrefslogtreecommitdiff
path: root/awklib/Makefile.am
diff options
context:
space:
mode:
authorArnold D. Robbins <arnold@skeeve.com>2010-07-16 13:17:58 +0300
committerArnold D. Robbins <arnold@skeeve.com>2010-07-16 13:17:58 +0300
commite888f1834b88270590b7e04d64c03c75863e4565 (patch)
treeab679ecbf16dc4f11b90a53f4b1e0084d78c98b0 /awklib/Makefile.am
parentfae4762eba9ff7bb466a600130e9c90eaac6b0bc (diff)
downloadgawk-e888f1834b88270590b7e04d64c03c75863e4565.tar.gz
Move to gawk-3.1.2.gawk-3.1.2
Diffstat (limited to 'awklib/Makefile.am')
-rw-r--r--awklib/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/awklib/Makefile.am b/awklib/Makefile.am
index d0f25284..4662ffc9 100644
--- a/awklib/Makefile.am
+++ b/awklib/Makefile.am
@@ -1,7 +1,7 @@
#
# awklib/Makefile.am --- automake input file for gawk
#
-# Copyright (C) 1995-2002 the Free Software Foundation, Inc.
+# Copyright (C) 1995-2003 the Free Software Foundation, Inc.
#
# This file is part of GAWK, the GNU implementation of the
# AWK Programming Language.
@@ -25,6 +25,10 @@
EXTRA_DIST = ChangeLog extract.awk eg stamp-eg
+# This is so we get config.h. It'll be in the build directory,
+# not the source directory.
+INCLUDES = -I..
+
datadir = @datadir@/awk
libexecdir = @libexecdir@/awk
@@ -58,10 +62,10 @@ stamp-eg: $(srcdir)/../doc/gawk.texi $(srcdir)/../doc/gawkinet.texi
@echo 'against a file, so this file is a place holder. gack.' >> stamp-eg
pwcat$(EXEEXT): $(srcdir)/eg/lib/pwcat.c
- $(CC) $(CFLAGS) $(srcdir)/eg/lib/pwcat.c $(LDFLAGS) -o $@
+ $(COMPILE) $(srcdir)/eg/lib/pwcat.c $(LDFLAGS) -o $@
grcat$(EXEEXT): $(srcdir)/eg/lib/grcat.c
- $(CC) $(CFLAGS) $(srcdir)/eg/lib/grcat.c $(LDFLAGS) -o $@
+ $(COMPILE) $(srcdir)/eg/lib/grcat.c $(LDFLAGS) -o $@
igawk: $(srcdir)/eg/prog/igawk.sh
cp $(srcdir)/eg/prog/igawk.sh $@ ; chmod 755 $@