summaryrefslogtreecommitdiff
path: root/libgo/testsuite/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libgo/testsuite/Makefile.am')
-rw-r--r--libgo/testsuite/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/libgo/testsuite/Makefile.am b/libgo/testsuite/Makefile.am
new file mode 100644
index 0000000000..8c6249d9d1
--- /dev/null
+++ b/libgo/testsuite/Makefile.am
@@ -0,0 +1,21 @@
+## Process this file with automake to produce Makefile.in.
+
+AUTOMAKE_OPTIONS = foreign dejagnu
+
+# Setup the testing framework, if you have one
+EXPECT = `if [ -f $(top_builddir)/../expect/expect ] ; then \
+ echo $(top_builddir)/../expect/expect ; \
+ else echo expect ; fi`
+
+RUNTEST = `if [ -f $(top_srcdir)/../dejagnu/runtest ] ; then \
+ echo $(top_srcdir)/../dejagnu/runtest ; \
+ else echo runtest; fi`
+
+# When running the tests we set GCC_EXEC_PREFIX to the install tree so that
+# files that have already been installed there will be found. The -B option
+# overrides it, so use of GCC_EXEC_PREFIX will not result in using GCC files
+# from the install tree.
+
+AM_RUNTESTFLAGS = "TEST_GCC_EXEC_PREFIX=$(libdir)/gcc"
+
+CLEANFILES = *.log *.sum