summaryrefslogtreecommitdiff
path: root/libitm/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'libitm/configure.ac')
-rw-r--r--libitm/configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/libitm/configure.ac b/libitm/configure.ac
index 3875aa0b47..c5ecd394a4 100644
--- a/libitm/configure.ac
+++ b/libitm/configure.ac
@@ -1,5 +1,5 @@
# Process this file with autoreconf to produce a configure script.
-# Copyright (C) 2011-2016 Free Software Foundation, Inc.
+# Copyright (C) 2011-2017 Free Software Foundation, Inc.
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -215,7 +215,7 @@ LIBITM_CHECK_ATTRIBUTE_DLLEXPORT
LIBITM_CHECK_ATTRIBUTE_ALIAS
# Check linker hardware capability support.
-LIBITM_CHECK_LINKER_HWCAP
+GCC_CHECK_LINKER_HWCAP
# If defaulting to -mavx, don't clear hwcaps.
AC_CHECK_DECL([__AVX__], [HWCAP_LDFLAGS=''])
@@ -286,5 +286,8 @@ AM_CONDITIONAL([ARCH_X86], [test "$ARCH" = x86])
AM_CONDITIONAL([ARCH_X86_AVX], [test "$libitm_cv_as_avx" = yes])
AM_CONDITIONAL([ARCH_FUTEX], [test $enable_linux_futex = yes])
+# Determine what GCC version number to use in filesystem paths.
+GCC_BASE_VER
+
AC_CONFIG_FILES(Makefile testsuite/Makefile libitm.spec)
AC_OUTPUT