summaryrefslogtreecommitdiff
path: root/libvtv/testsuite/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libvtv/testsuite/Makefile.am')
-rw-r--r--libvtv/testsuite/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/libvtv/testsuite/Makefile.am b/libvtv/testsuite/Makefile.am
index a2c1e9f4ea..561b7e2544 100644
--- a/libvtv/testsuite/Makefile.am
+++ b/libvtv/testsuite/Makefile.am
@@ -1,11 +1,13 @@
-## Process this with automake to create Makefile.in
+## Process this file with automake to produce Makefile.in.
AUTOMAKE_OPTIONS = foreign dejagnu
-EXPECT = `if [ -f ../../expect/expect ] ; then \
- echo ../../expect/expect ; \
- else echo expect ; fi`
+# May be used by various substitution variables.
+gcc_version := $(shell cat $(top_srcdir)/../gcc/BASE-VER)
-RUNTEST = `if [ -f ${srcdir}/../../dejagnu/runtest ] ; then \
- echo ${srcdir}/../../dejagnu/runtest ; \
- else echo runtest ; fi`
+EXPECT = $(shell if test -f $(top_builddir)/../expect/expect; then \
+ echo $(top_builddir)/../expect/expect; else echo expect; fi)
+
+_RUNTEST = $(shell if test -f $(top_srcdir)/../dejagnu/runtest; then \
+ echo $(top_srcdir)/../dejagnu/runtest; else echo runtest; fi)
+RUNTEST = "$(_RUNTEST) $(AM_RUNTESTFLAGS)"