summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTom de Vries <tdevries@suse.de>2022-09-07 13:19:05 +0200
committerTom de Vries <tdevries@suse.de>2022-09-07 13:19:05 +0200
commit04bb15e48ef8dd3d6a5ff30723c603cef3e0a3c6 (patch)
tree99044e58ef203995ee12a3a984fe0d1f35b2757c /configure.ac
parent22cefe5c22a90d20e2d9f629402b0522c03fa59c (diff)
downloadgcc-04bb15e48ef8dd3d6a5ff30723c603cef3e0a3c6.tar.gz
[gdb/build] Fix build breaker with --enable-shared
When building gdb with --enable-shared, I run into: ... ld: build/zlib/libz.a(libz_a-inffast.o): relocation R_X86_64_32S against \ `.rodata' can not be used when making a shared object; recompile with -fPIC ld: build/zlib/libz.a(libz_a-inflate.o): warning: relocation against \ `inflateResetKeep' in read-only section `.text' collect2: error: ld returned 1 exit status make[3]: *** [libbfd.la] Error 1 ... This is a regression since commit a08bdb159bb ("[gdb/build] Fix gdbserver build with -fsanitize=thread"). The problem is that a single case statement in configure is shared to handle special requirements for both the host libiberty and host zlib, which has the effect that only one is handled. Fix this by handling libiberty and zlib each in its own case statement. Build on x86_64-linux, with and without --enable-shared. ChangeLog: 2022-09-07 Tom de Vries <tdevries@suse.de> * configure.ac: Set extra_host_libiberty_configure_flags and extra_host_zlib_configure_flags in separate case statements. * configure: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3ecb532138d..3cfd9b41fca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2439,13 +2439,18 @@ fi
# Sometimes we have special requirements for the host libiberty.
extra_host_libiberty_configure_flags=
-extra_host_zlib_configure_flags=
case " $configdirs " in
*" lto-plugin "* | *" libcc1 "* | *" gdbserver "*)
# When these are to be built as shared libraries, the same applies to
# libiberty.
extra_host_libiberty_configure_flags=--enable-shared
;;
+esac
+AC_SUBST(extra_host_libiberty_configure_flags)
+
+# Sometimes we have special requirements for the host zlib.
+extra_host_zlib_configure_flags=
+case " $configdirs " in
*" bfd "*)
# When bfd is to be built as a shared library, the same applies to
# zlib.
@@ -2454,7 +2459,6 @@ case " $configdirs " in
fi
;;
esac
-AC_SUBST(extra_host_libiberty_configure_flags)
AC_SUBST(extra_host_zlib_configure_flags)
# Produce a warning message for the subdirs we can't configure.