summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorbstarynk <bstarynk@138bc75d-0d04-0410-961f-82ee72b054a4>2010-03-13 09:26:30 +0000
committerbstarynk <bstarynk@138bc75d-0d04-0410-961f-82ee72b054a4>2010-03-13 09:26:30 +0000
commit97d5b1d7e0a22a617a1994d529c260be60c2ec03 (patch)
tree44d0fdc688d5d0aff330dae14b52ee30c6a4bd13 /configure.ac
parent34185534d1a9f2732b6f3a62680b2caaefddcee6 (diff)
downloadgcc-97d5b1d7e0a22a617a1994d529c260be60c2ec03.tar.gz
2010-03-13 Basile Starynkevitch <basile@starynkevitch.net>
{{can be compiled as a plugin, and removed every GDBM stuff.}} * configure.ac: removed every GDBM related stuff. * configure: regenerated. * contrib/build-melt-plugin.sh: added file. * gcc/configure.ac: removed GDBM stuff. * gcc/common.opt: removed GDBM related option -fmelt-gdbmstate=. * gcc/melt-make.mk: added/renamed several variables, such as: melt_make_module_makefile melt_make_cc1 melt_make_gencdeps ... * Makefile.in: corrected accordingly, and removed GDBM stuff. * gcc/melt-runtime.h (melt_has_gdbmstate) (meltgc_fetch_gdbmstate_constr, meltgc_fetch_gdbmstate) (meltgc_put_gdbmstate_constr, meltgc_put_gdbmstate): removed declarations. * gcc/melt-runtime.c: Don't include <gdbm.h> anymore. (melt_argument): handle "option", but no more "gdbmstate". (melt_debug_depth): uses melt_argument. (compile_module_to_binary): dlfile replaced by binfile when MELT_IS_PLUGIN. (load_melt_modules_and_do_mode): use melt_argument for option. (plugin_init): use gcc_version->basever... when MELT_IS_PLUGIN. (meltgdbmstate): removed variable. (melt_has_gdbmstate, get_melt_gdbm, fatal_gdbm) (meltgc_fetch_gdbmstate_constr, meltgc_fetch_gdbmstate) (meltgc_put_gdbmstate_constr, meltgc_put_gdbmstate): removed functions. * gcc/melt/xtramelt-ana-base.melt: removed GDBM related code. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/branches/melt-branch@157420 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 1 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index 52e7592ba0a..55643320d2c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -167,7 +167,7 @@ build_tools="build-texinfo build-byacc build-flex build-bison build-m4 build-fix
# these libraries are used by various programs built for the host environment
#
-host_libs="intl mmalloc libiberty opcodes bfd readline tcl tk itcl libgui zlib libcpp libdecnumber gmp mpfr mpc ppl gdbm cloog libelf libiconv"
+host_libs="intl mmalloc libiberty opcodes bfd readline tcl tk itcl libgui zlib libcpp libdecnumber gmp mpfr mpc ppl cloog libelf libiconv"
# these tools are built for the host environment
# Note, the powerpc-eabi build depends on sim occurring before gdb in order to
@@ -1629,30 +1629,6 @@ AC_ARG_ENABLE(lto,
enable_lto=$enableval,
enable_lto=yes; default_enable_lto=yes)
-# Check for GDBM needed for MELT
-gdbmlibs="-lgdbm"
-gdbminc=""
-
-AC_ARG_WITH(gdbm_include, [ --with-gdbm-include=PATH Specify directory for installed GDBM include files])
-AC_ARG_WITH(gdbm_lib, [ --with-gdbm-lib=PATH Specify the directory for the installed GDBM library])
-
-if test "x$with_gdbm_include" != x; then
- gdbminc="-I$with_gdbm_include "
-fi
-if test "x$with_gdbm_lib" != x; then
- gdbmlibs="-L$with_gdbm_lib -lgdbm"
-fi
-LIBS="$gdbmlibs $LIBS"
-
-AC_MSG_CHECKING([for GDBM])
-AC_TRY_LINK([#include "gdbm.h"],[GDBM_FILE gf = gdbm_open("testdbm",0,GDBM_WRITER,0,0);],
- [AC_MSG_RESULT([yes]); have_gdbm=yes],
- [AC_MSG_RESULT([no]); have_gdbm=no])
-
-# Flags needed for GDBM
-AC_SUBST(gdbmlibs)
-AC_SUBST(gdbminc)
-
if test x"$enable_lto" = x"yes" ; then
# Make sure that libelf.h and gelf.h are available.