summaryrefslogtreecommitdiff
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorRainer Orth <ro@CeBiTec.Uni-Bielefeld.DE>2014-04-24 08:38:06 +0000
committerRainer Orth <ro@gcc.gnu.org>2014-04-24 08:38:06 +0000
commitab0afae309610d5a0ddcdf346e1927dcf9e50066 (patch)
tree0b5805dc1aa07758e01935f741f8a9dfc731db43 /gcc/configure.ac
parent1e7251a72530233484651b91b046917d7b711a59 (diff)
downloadgcc-ab0afae309610d5a0ddcdf346e1927dcf9e50066.tar.gz
Fix gcc_cv_as_cfi_directive test for Solaris as
* configure.ac (gcc_cv_as_cfi_directive): Support Solaris/x86 assembler 64-bit option. * configure: Regenerate. From-SVN: r209739
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index d78955774c4..1235501bd49 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -2544,9 +2544,14 @@ gcc_GAS_CHECK_FEATURE([cfi directives], gcc_cv_as_cfi_directive,
else
case "$target" in
i?86-*-solaris2.1[[0-9]]* | x86_64-*-solaris2.1[[0-9]]*)
- # On Solaris/x86, make sure that GCC and gas agree on using
+ # On Solaris/x86, make sure that GCC and assembler agree on using
# read-only .eh_frame sections for 64-bit.
- if $gcc_cv_as --64 -o conftest.o conftest.s > /dev/null 2>&1 && \
+ if test x$gas = xyes; then
+ as_ix86_64_opt="--64"
+ else
+ as_ix86_64_opt="-xarch=amd64"
+ fi
+ if $gcc_cv_as $as_ix86_64_opt -o conftest.o conftest.s > /dev/null 2>&1 && \
$gcc_cv_objdump -h conftest.o 2>/dev/null | \
sed -e /.eh_frame/!d -e N | \
grep READONLY > /dev/null; then